Fwd: Re: [Mailman-Users] Problems with upgrading

mackay at kodak.com mackay at kodak.com
Thu May 25 16:42:13 CEST 2000

From: Scott D. MacKay

This could be a problem with the configuration of the mailman.  I believe
the error being reported is passed from the wrapper app.  The app is the
one reporting the error to the mail server which then dies out..  I don't
have the previous emails readily available, so forgive me if you already
answered this...
What was your mailman  --with-mail-gid configure option?  Did it include
the group that mail uses?  It really sounds like it does not recognise the
group mail is invoking the app with as being an allowed group.  I would
compare the GID you configured against the one used by your sendmail.

If you enabled SYSLOG for mailman, you should have an even logged at
LOG_MAIL/LOG_ERR level showing the expected and received GID.
This is seen from src/mail-wrapper.c in the main() where it invokes
check_caller() (common.c).

I believe the 'INSTALL' document is inaccurate with respect to
--with-mail-gid says you can use multiple GID values.  The mail-wrapper.c
assigns the variable parentgid to LEGAL_PARENT_GID which is defined as
MAIL_GID which is a '-D' macro passed in.  I see no looping in the
check_caller() and no array in mail-wrapper.c to cycle through each GID
provided.  In addition, it MUST be an integer value (give the C code).  In
short, only 1 GID, and it must be the integer value of the GID.


Aaryn Olsson <aaryn at Ag.Arizona.Edu> on 05/24/2000 06:46:30 PM

To:   mackay at kodak.com
cc:   mailman-users at python.org (bcc: Scott D. MacKay/943904/EKC)
Subject:  Re: Fwd: Re: [Mailman-Users] Problems with upgrading

Dear Mr. MacKay,

This is what I get when I run the command you suggested:

% echo hi | /usr/lib/sendmail -v -bv theclub
theclub... aliased to "|/usr/local/mail/mailman/mail/wrapper post theclub"
"|/usr/local/mail/mailman/mail/wrapper post theclub"... deliverable:
mailer prog, user "|/usr/local/mail/mailman/mail/wrapper post theclub"

Everything is installed on the same machine: ag.arizona.edu.

Incidentally, majordomo-1.94.5 works, but we had to add that
"DontBlameSendmail..." line for Group Writable directories.  This is what
those aliases looke like:

studentnews: "|/opt/local/mail/majordomo/wrapper resend -p bulk -M 10000
-l stud
entnews -f studentnews-owner -h ag.arizona.edu studentnews-outgoing"

sendmail -v -vb studentnews gives a message similar to that of theclub.

Still need help,

On Wed, 24 May 2000 mackay at kodak.com wrote:

> Date: Wed, 24 May 2000 17:03:54 -0400
> From: mackay at kodak.com
> To: Aaryn Olsson <aaryn at Ag.Arizona.Edu>
> Subject: Re: Fwd: Re: [Mailman-Users] Problems with upgrading
> From: Scott D. MacKay
> It does look like a sendmail problem.
> Have you tried
> /usr/lib/mail/sendmail -v -bv theclub
> Also, which machine is mailman installed on?  Are you sure the machine it
> is installed on is the one who is parsing the email name?
> -Scott
> Aaryn Olsson <aaryn at Ag.Arizona.Edu> on 05/24/2000 04:47:26 PM
> To:   Michael Rose <mar at Ag.Arizona.Edu>
> cc:   mailman-users at python.org (bcc: Scott D. MacKay/943904/EKC)
> Subject:  Re: Fwd: Re: [Mailman-Users] Problems with upgrading
> David
> Thanks for your input.  From your message it is hard to tell what you
> mean about the /etc/aliases.  This is what the /etc/aliases look like:
> ## theclubs mailing list
> theclub: "|/usr/local/mail/mailman/mail/wrapper post theclub"
> theclub-admin: "|/usr/local/mail/mailman/mail/wrapper mailowner theclub"
> theclub-request: "|/usr/local/mail/mailman/mail/wrapper mailcmd theclub"
> theclub-owner: theclub-admin
> owner-theclub: theclub-admin
> /usr/local/mail/mailman/mail/wrapper is the full path of wrapper and when
> I run it from the command line, I get an exit code of 5 which I think is
> from common.c: #define MAIL_USAGE_ERROR 5.  On that note, an exit code of
> 2 corresponds to #definte GID_MISMATCH 2.  Group ID mismatch?  But all
> files in the /usr/local/mail/mailman directory subtree belong to the
> mailman group.  Also, does the owner of the files matter?  Who should own
> wrapper?  I've tried me, root, and mailman, all to no avail.
> mailman is a Trusted user as far as sendmail is concerned, and
> has a line called "O
> but I don't think that's a problem considering the exit code sounds like
> it comes from wrapper itself.
> Very confused.  Please help.
> Sincerly,
> Aaryn Olsson

More information about the Mailman-Users mailing list