[Mailman-Users] Can't get it working

Brett Goldstock bgoldstock at tvdata.com
Thu Nov 9 20:02:41 CET 2000

I've been trying for a few days to get Mailman working reliably, but 
I keep running into problems. I'm running Solaris 2.7 on an Ultra 60 
with Apache 1.3.9.

I originally compiled it under a user called mailman, but my Apache 
uses a User and Group setting of "nobody". This sort of worked, but 
my config.db file kept getting reset to an owner of "nobody", causing 
errors in the Mailman log. If I reset the ownership to mailman, my 
message don't get delivered and I get no errors in any log.

I recompiled under mailman using the --with-mail-gid and 
--with-cgi-gid both set to "nobody". Now I get the following:

    ----- The following addresses had permanent fatal errors -----
"|/usr/local/mailman/mail/wrapper post test"
     (reason: 2)
     (expanded from: test)

    ----- Transcript of session follows -----
Failure to exec script. WANTED gid 60001, GOT gid 1.  (Reconfigure to take 1?)
554 5.3.0 "|/usr/local/mailman/mail/wrapper post test"... unknown 
mailer error 2

I'm a little confused. I've read the INSTALL file, but I'm still not 
sure what I'm doing wrong.



More information about the Mailman-Users mailing list