[Mailman-Users] Archives failing after upgrade

Mentor Cana mentor at alb-net.com
Mon Nov 13 20:00:40 CET 2000

Same with my installation.


On Mon, 13 Nov 2000, at 10:30, Edmund Lau wrote:

> I upgraded Mailman from rc1 to rc2 over the weekend but evidently there
> were some problems.  My web archives for all my lists are failing.  Here's
> a traceback after running bin/arch <listname>:
> ---
> Traceback (most recent call last):
>   File "./arch", line 129, in ?
>     main()
>   File "./arch", line 118, in main
>     archiver.processUnixMailbox(fp, Article)
>   File "/home/mailman/Mailman/Archiver/pipermail.py", line 521, in
> processUnixMailbox
>     a = articleClass(m, self.sequence)
>   File "/home/mailman/Mailman/Archiver/HyperArch.py", line 224, in
> __init__
>     self.cenc = string.lower(cenc)
>   File "/usr/local/pkg/python-1.6/lib/python1.6/string.py", line 47, in
> lower
>     return s.lower()
> AttributeError: 'None' object has no attribute 'lower'
> ---
> When qrunner is queueing an Email for a list delievery, there is an extra
> line of errors in my error log which basically says my archieve is
> corrupt.
> The good thing is, nothing is really lost because I can still see them
> being stored in the mbox file so I can reconstruct them later.  I was
> thinking my situation might be related to what Greg Connor recently went
> through but our tracebacks are different.  At the moment, arch fails on
> all my lists, whether there were pending requests or not.  I went back
> through the logs and discovered that when I had upgraded there were two
> lists (out of the 6 I'm running) with admin requests waiting.
> Anyone with ideas on how to start debugging so I can be back in a "sane"
> state?  Thanks!
> -Ed
> ------------------------------------------------------
> Mailman-Users maillist  -  Mailman-Users at python.org
> http://www.python.org/mailman/listinfo/mailman-users

More information about the Mailman-Users mailing list