[Mailman-Users] mailcmd silent failure: RH7.1+postfix

Michelle Dick artemis at rahul.net
Sun Aug 5 00:58:03 CEST 2001

I run a mailing list on a combo of exim+smartlist and want to switch
it to a new system that will run postfix+mailman instead.

It is a Redhat 7.1 system with the Redhat powertools postfix rpm on

I compiled the 2.0.6 version of mailman for the system and read the
instructions on working with postfix.  I no longer get the GID errors
after I compiled it using the --with-mail-gid setting.

I set up a list and can add addresses via web administration.  I tried
using the web interface as a user and requesting subscription.  It
sent a confirmation request email and I replied to it.  But then,
nothing happened.

The logs/subscribe file lists the pending request for subscription,
there is nothing in the errors file, and postfix logs indicated the
reply was received and passed off to mailcmd.

I tried it both with and without the wrapper script, I tried feeding
mailcmd a message on the command line -- same result.  mailcmd fails
to do anything, silently.

Is there a python version of "sh -x" or verbose/debug I can turn on in
mailcmd to have it tell me what is (not) doing?

Michelle Dick
artemis at rahul.net

More information about the Mailman-Users mailing list