[Mailman-Users] getting cgi-gid right

Jim Gottlieb jimmy at nccom.com
Wed Dec 19 02:24:43 CET 2001

We're retiring the machine running majordomo, so I figure this is a
good excuse to switch to Mailman. 

I've built and installed and set up the 'test' list as suggested in the
INSTALL file, but when I try accessing the web page, I get:

	Mailman CGI error!!!

	The expected gid of the Mailman CGI wrapper did not match the gid as
	set by the Web server.

I have tried rebuilding it with a few different cgi-gid definitions,
but still can't get past this.  I created a cgi-bin script that does
nothing but create a file and it shows:

-rw-------   1 nobody   daemon          0 Dec 18 14:59 /tmp/cgi

confirming for me that the web server is running as group daemon, and I
did a full reconfigure and rebuild of mailman with

but I still get this error.  Is there some place I can see what GID it
wants and what GID it is seeing?

syslog shows:
Mailman cgi-wrapper (admin): No such file or directory

So is some file missing or is it the GID mismatch?  What's a good way
to debug this?

Running Mailman 2.0.7 under Solaris 8 and Python 1.5.2.

Thanks for any help.

More information about the Mailman-Users mailing list