[Mailman-Users] serious gid problem

Brian Cohen brian at acm.jhu.edu
Thu Feb 15 16:12:00 CET 2001

I had this problem too, and I found a solution.  Basically, I had to tell
my MTA (Postfix, in my case) to execute external programs as the same user
I specified with --with-mail-gid.  So for example, if you did
--with-mail-gid=mailman, then you need to somehow reconfigure Sendmail to
execute external programs as 'mailman'.  I have virtually no experience
with Sendmail (gave up on it long ago) so I don't know how, or whether,
this could be done.  In Postfix, I had to un-comment the 'default_privs'
option in main.cf and set it as 'default_privs = mailman'.

I know a lot of other people are having this problem too, so I hope this
helps a little.


On Thu, 15 Feb 2001, Julio Cesar J Melati wrote:

> hello all :)
> recently i upgrade the mailman version beta2 for beta5. in beta2 all work.
> but now, i'm get the error "wanted gid 501, got gid 65535. reconfigure?". i
> know who need recompile for gid 65535 with the parameter with-mail-gid. but
> i can't put the mailman in the group 65535. what is happened?
> box conectiva linux 5.1 (brazilian distribuition like redhat)
> sendmail 8.9.3, apache 1.3.12.
> sorry, my english is poor, but my soul is better :)
> ------------------------------------------------------
> Mailman-Users maillist  -  Mailman-Users at python.org
> http://mail.python.org/mailman/listinfo/mailman-users

More information about the Mailman-Users mailing list