[Mailman-Users] upgrading Python and mailman

Dan Mick dan.mick at west.sun.com
Mon Jan 29 23:49:10 CET 2001

Known problem with old Python code.  Upgrade to Mailman 2.0.1 and all will be well again.
(Mailman started supporting Python 2.0 sometime around 2.0beta3 if I remember right.)

> Ray Gardener wrote:
> We are currently using Python version 1.5.1 and Mailman version 1.0. We wish to move to Mailman version 2.0. In
> preparation for this I installed Python version 2.0. A bad thing was noticed ;-) mail was accepted into mailman but
> not distributed out. Looking at the smtp-failures log file I see  messages of the following type
> 28 10:07:04 2001 TrySMTPDelivery: To ['A.D.Person at shu.ac.uk', 'J.Someone at shu.ac.uk']:
> Jan 29 10:09:26 2001 TrySMTPDelivery: exceptions.TypeError / connect requires exactly 1 argument; 2 given (dequeued)
> Is/was this a known problem and if so can I expect the same thing using version 1.5.2 of Python (the minimum for
> installing version 2 of mailman)?
> Regards
> Incidentally [to add to the list of MTA mailman is known to work with] I have installed it with Nexor's PP or Mailer
> software and will write up the installation quirks if anyone is interest.

More information about the Mailman-Users mailing list