[Mailman-Users] Upgrage Problems

Ian MacLeod highlander at engsoc.queensu.ca
Sat Jul 7 17:05:24 CEST 2001

I thank eveyrone in advance for helping me out :-)

I've attempted an upgrade from mailman 1.x to 2.x

Installation went fine, however, the old lists wern't picked up (even
though installation was to the same directory /usr/lib/mailman).

Also I can only create lists... I get python errors mailed to me whenever
I try anything :

Subject: Cron <list at engsoc> [ -x /usr/bin/python -a -f
    /usr/lib/mailman/cron/gate_news ] && /usr/bin/python

Traceback (innermost last):
  File "/usr/lib/mailman/cron/gate_news", line 222, in ?
  File "/usr/lib/mailman/cron/gate_news", line 198, in main
  File "/usr/lib/mailman/Mailman/LockFile.py", line 219, in lock
  File "/usr/lib/mailman/Mailman/LockFile.py", line 350, in __write
    fp = open(self.__tmpfname, 'w')
IOError: [Errno 13] Permission denied:

also the same error when the /usr/lib/mailman/run_queue script is
run.  When i run check_perms as root, permissions check out OK, then i run
as mailman and I get this error :

mailman at engsoc:/usr/lib/mailman/bin$ ./check_perms
Traceback (innermost last):
  File "./check_perms", line 279, in ?
  File "./check_perms", line 161, in checkarchivedbs
    for dir in os.listdir(mm_cfg.PRIVATE_ARCHIVE_FILE_DIR):
OSError: [Errno 13] Permission denied

I'll admit there were problems with the old version, mind you it was
running for a number of years.

The web stuff doesn't work either. (I get the 'bug' error)



More information about the Mailman-Users mailing list