[Mailman-Users] Need some help, lost messages, now getting "caught a bug error" on admin page

Ed Wilts ewilts at ewilts.org
Mon Jun 18 03:13:52 CEST 2001

On Sunday 17 June 2001 06:54 pm, you wrote:
> I'm really hoping that someone can help me with this:
> Mailman says that it's lost 4 messages.  There's no trace of them in
> mailman/data, and in /mailman/logs/vette, they're all listed as
> discarded posting -- does that mean that a list admin discarded them?

It could be that mailman discarded them.  Check to see if they're still in 
the data directory.

> if so, then why do they appear as lost messages on the admin web page,
> and is there any relationship to the bug message that's appearing at the
> bottom of the admin requests page?

Yup - the bug message is the same problem.

> for what's worth, I'm running Mailman 2.0.5 on a Redhat 7.1 machine.
> here's the error from the log:

Been there, done that.

> admin(27298):     fp = open(self.__filename, 'w')
> admin(27298): IOError: [Errno 13] Permission denied:
> '/var/mailman/lists/oc/request.db'

That's the answer right there.  The mailman application can't open the 
request.db file for write.  To fix it when I ran into it:

# chown apache.mailman /var/mailman/lists/*/request.db
# chmod 664 /var/mailman/lists/*/request.db

It worked for me.  Whether that was the right answer or only answer I don't 


Ed Wilts, Mounds View, MN, USA
mailto:ewilts at ewilts.org

More information about the Mailman-Users mailing list