[Mailman-Users] list works / admin does not?

Shannon Anderson sanderson at squidworks.net
Tue Jun 19 23:31:04 CEST 2001

Hi all,

Just installed mailman this week and have spent some time with it figuring
out the basics.

Created 2 new lists, added wrappers to aliases file. lists are working both
posts and send-outs but the admin pages from the get-go have been erroring
out. Looking in the logs at the traceback (error log below) it seems to be a
erroring tring to open a file where permissions are applied about 15 lines
down, or is this a result of another problem?

Jun 19 17:17:35 2001 admin(12542):
admin(12542): [----- Mailman Version: 2.0.5 -----]
admin(12542): [----- Traceback ------]
admin(12542): Traceback (innermost last):
admin(12542):   File "/usr/mailman/scripts/driver", line 96, in run_main
admin(12542):     main()
admin(12542):   File "/usr/mailman/Mailman/Cgi/admin.py", line 143, in main
admin(12542):     mlist.Lock()
admin(12542):   File "/usr/mailman/Mailman/MailList.py", line 1338, in Lock
admin(12542):     self.__lock.lock(timeout)
admin(12542):   File "/usr/mailman/Mailman/LockFile.py", line 219, in lock
admin(12542):     self.__write()
admin(12542):   File "/usr/mailman/Mailman/LockFile.py", line 350, in
admin(12542):     fp = open(self.__tmpfname, 'w')
admin(12542): IOError: [Errno 13] Permission denied:
admin(12542): [----- Python Information -----]
admin(12542): sys.version    = 1.5.2 (#1, Aug 25 2000, 09:33:37)  [GCC 2.96
20000731 (experimental)]
admin(12542): sys.executable = /usr/bin/python
admin(12542): sys.prefix     = /usr
admin(12542): sys.exec_prefix= /usr
admin(12542): sys.path       = /usr
admin(12542): sys.platform   = linux-i386
admin(12542): [----- Environment Variables -----]
admin(12542): 	DOCUMENT_ROOT: /var/www/html
admin(12542): 	SERVER_ADDR:
admin(12542): 	HTTP_ACCEPT_ENCODING: gzip, deflate
admin(12542): 	CONTENT_LENGTH: 14
admin(12542): 	CONTENT_TYPE: application/x-www-form-urlencoded
admin(12542): 	PATH_TRANSLATED: /var/www/html/slug
admin(12542): 	REMOTE_ADDR:
admin(12542): 	SERVER_SOFTWARE: Apache/1.3.12 (Unix)  (Red Hat/Linux)
mod_ssl/2.6.6 OpenSSL/0.9.5a mod_perl/1.24
admin(12542): 	HTTP_COOKIE:
admin(12542): 	HTTP_ACCEPT_LANGUAGE: en-us
admin(12542): 	GATEWAY_INTERFACE: CGI/1.1
admin(12542): 	SERVER_PORT: 80
admin(12542): 	HTTP_CONNECTION: Keep-Alive
admin(12542): 	HTTP_USER_AGENT: Mozilla/4.0 (compatible; MSIE 5.01; Windows
NT 5.0)
admin(12542): 	HTTP_ACCEPT: */*
admin(12542): 	REQUEST_URI: /mailman/admin/slug
admin(12542): 	HTTP_CACHE_CONTROL: no-cache
admin(12542): 	QUERY_STRING:
admin(12542): 	SERVER_PROTOCOL: HTTP/1.1
admin(12542): 	PATH_INFO: /slug
admin(12542): 	HTTP_HOST: www.squidworks.net
admin(12542): 	REQUEST_METHOD: POST
admin(12542): 	SERVER_SIGNATURE: <ADDRESS>Apache/1.3.12 Server at www Port

admin(12542): 	SCRIPT_NAME: /mailman/admin
admin(12542): 	SERVER_ADMIN: webmaster at squidworks.net
admin(12542): 	SCRIPT_FILENAME: /usr/mailman/cgi-bin/admin
admin(12542): 	PYTHONPATH: /usr/mailman
admin(12542): 	HTTP_REFERER: http://www.squidworks.net/mailman/admin/slug
admin(12542): 	SERVER_NAME: www
admin(12542): 	REMOTE_PORT: 63386

Any Ideas why this would stop the admin site from showing up correcrly??

Shannon M. Anderson
sanderson at squidworks.net <mailto:sanderson at squidworks.net>

More information about the Mailman-Users mailing list