[Mailman-Users] qrunner -- problem with huge mail messages

Dirko van Schalkwyk dvschalk at ing.sun.ac.za
Mon Jun 25 22:53:06 CEST 2001


I have the following situation : 

Mailman 2.0.5 
Python 2.0
MTA : postfix

I set Mailman up, created a test list and played with it
for a while.
Then I send it a big "whopper" 5MB e-mail. I watched the
logs and saw
postfix running the wrapper. The cron started qrunner and
all hell broke
lose (over dramatizing a bit). It started running at 100%
CPU, where it
stayed until I killed it. The message was queued in
$prefix/qfiles, it
and its little .db file. I had to remove those as well as
the locks in
$prefix/locks before I could successfully use the list

So I thought, "well maybe the pipermail thingy can't
handle the huge
mime thingies I'm sending it". So I send a smaller
attachment <150kb.
Things went fine (except for the ugly html page:) ) Send
it a 1MB
attachment. qrunner started spinning it's wheels again.
Had to seek and
destroy again.

So I replaced pipermail with MHonArc (With
mm_cfg.py and the
appropriate thingies in httpd.conf). Small messages
worked fine. Big 
whoppers = no joy i.e. still the same with big messages.
So at least it
is not the archiving bit that messes up.

So I upgraded my Python ;) Ermm, to version 2.0. Still
the same.

Has anyone had the same problem? Can anyone confirm this
as a bug by
sending a 2MB file to a 2.0.5 testlist? 

How do I do a trace in Python? (i.e. it is as familiar to
me as the
bacteria in my stomach (I runs on my machine and there
endeth the

Any pointers? Anything? 



Lab E352
E&E Engineering
Univ. of Stellenbosch
South Africa

More information about the Mailman-Users mailing list