[Mailman-Users] Web interface went to Brazil for summer vacation?

Satya satyap at satya.virtualave.net
Fri Jun 29 23:50:49 CEST 2001

On Jun 29, 2001 at 12:06, Amanda wrote:

>with them to the Other Place. (foo.net/mailman/admin/testlist gives a

[short recap: tried the usual, got nothing]

Sounds like your Apache directory structure might be twisted. I didn't
follow this completely, but if the document root for Apache is
/usr/local/apache/www/htdocs and you're getting:

File does not exist:

in the logs, then maybe mailman's stuff should be in
/usr/local/apache/www/htdocs/ on the filesystem. That is if the Alias
directive, as below, is missing.

You mentioned ScriptAlias. I have this:

Alias /mailman/ /home/mailman/cgi-bin/

Do you have a similar line? Is it correct?


I just checked. My logs, with things working correctly, show this: - - [30/Jun/2001:03:17:56 +0530] "GET / HTTP/1.0" 200 6394 - - [30/Jun/2001:03:18:00 +0530] "GET /mailman/
HTTP/1.0" 200 197 - - [30/Jun/2001:03:18:01 +0530] "GET /mailman/admin.cgi
HTTP/1.0" 200 2668 - - [30/Jun/2001:03:18:07 +0530] "GET
/mailman/admin.cgi/dfedit HTTP/1.0" 200 1327

Note the paths. They're in Apache's web directory space, not in the
filesystem. Your path is in the filesystem. Borked Alias directive is
my guess.

>I realize I'm a little frazzled from days and nights on end untangling
>(unrelated) scripts and may be missing something obvious ... If anyone
>has any suggestions, I'm all ears.

I'm not very awake either.

BTW, who else has admin access to the box in question? Maybe they
did something?

More wild guessing: is /usr/local/apache/www/htdocs/ or anything along
that path on a different partition which isn't mounted?

Server version: Apache/1.3.12 (Unix)  (Red Hat/Linux)
Mailman version: 2.0.1 

Satya. <URL:http://satya.virtualave.net/>
US-bound grad students! For pre-apps, see <URL:http://quickapps.cjb.net/>
ISDN: It Still Does Nothing

More information about the Mailman-Users mailing list