[Mailman-Users] Problems with the wrapper program - *Lots* of detail.

Pete Phillips pete at smtl.co.uk
Thu Mar 1 15:03:15 CET 2001


I too am experiencing problems with 2.0.1 mailman and the wrapper GID
problem. Enclosed below are, hopefully, enough snippets someone to
solve the problem.

Firstly - yes, I have followed the INSTALL (as I understand it), read
the FAQ, searched the python.org archives, and searched all of this
years mailman digests.


	Platform:  Red Hat Linux 6.0 , Kernel 2.2.17 on an i686
	Mailman: 2.0.1
	MTA: sendmail-8.11.0

On sending the confirmation reply to a subscription request, I get the 
following in my sendmail log:

	Mar 1 11:53:58 ds9 Mailman mail-wrapper: Failure to exec
	script. WANTED gid 1, GOT gid 12.  (Reconfigure to take 12?)

Here is my configuration line:

	./configure  --prefix=/share/store/mailman-2.0.1

(BTW - I tried with numerical gid 12 instead of 'mail' - same problem. )

As you can see, it is configured for 12/mail (see group file entry below).

However, if I run the following by hand:
	   /share/mailman/linux/mail/wrapper mailcmd test2

I get 

	Failure to exec script. WANTED gid 12, GOT gid 0.
	(Reconfigure to take 0?)

I.e., the wrapper here seems to understand that gid of 12 is required, 
but it is getting 0 (because I ran this as root from the command line

My sendmail.cf contains the following:
	   O DefaultUser=8:12

My /etc/group file contains:

      ls -al /etc/smrsh/wrapper
      lrwxrwxrwx   1 root     root           33 Aug  8  2000 /etc/smrsh/wrapper -> /share/mailman/linux/mail/wrapper

Any help *deeply* appreciated :-)


Pete Phillips, Deputy Director,     | Visit  http://www.smtl.co.uk/ 
Surgical Materials Testing Lab,     | A web site dedicated to medical
Princess of Wales Hospital, S. Wales| disposables, dressings, wound care
Fax: +44 1656-752830 pete at smtl.co.uk| and biosurgery (maggot therapy).

More information about the Mailman-Users mailing list