[Mailman-Users] config.db changes ownership

Michael Deck deckm at cleansoft.com
Wed Mar 21 05:38:07 CET 2001

I'm sure this is a configuration problem somewhere but, I managed to get 
everything working nicely though there were a few steps that weren't in the 
book. $prefix is /home/mailman, and my Apache server says Group=nobody. So 
I tried

   ./configure --with-ownergroup=mailman --with-mail-gid=mailman 

But this failed to send mail, with a log in qmail saying it expected 509 
(nofiles) got 512 (mailman). So I tried

   ./configure --with-ownergroup=mailman --with-mail-gid=nofiles 

This works after doing two things that feel unnatural. First, since the 
configure and make are being done sudo, all the files under $prefix have 
owner root. So I chown -R mailman . in the mailman directory. Ok, now I can 
create a list, send a subscribe from the web interface, and get confirm 
request. But when I reply to the confirm request, nothing happens. I tried 
list_members and I get

Traceback (innermost last):
   File "bin/list_members", line 141, in ?
   File "bin/list_members", line 115, in main
     mlist = MailList.MailList(listname, lock=0)
   File "/home/mailman/Mailman/MailList.py", line 79, in __init__
   File "/home/mailman/Mailman/MailList.py", line 891, in Load
     dict, e = self.__load(dbfile)
   File "/home/mailman/Mailman/MailList.py", line 868, in __load
     fp = open(dbfile)
IOError: [Errno 13] Permission denied: '/home/mailman/lists/test2/config.db'

I look at config.db and its ownership has switched back to 'nobody'. If I 
chown it and re-send my confirmation, everything works and the list manages 
fine. But the next subscribe request hoses it again.

I feel close -- what's the secret?


Michael Deck
Cleanroom Software Engineering, Inc.   

More information about the Mailman-Users mailing list