[Mailman-Users] Re: New 2.0.6 install, input OK, output nil - problem solved

Bill Horne billhorne at mediaone.net
Tue Oct 9 11:59:42 CEST 2001

Oliver Egginger wrote:

> I am very sure that this has something to do with your MTA.
> The smtp log (within the mailman logs) is only the client-side.
> Consult the log-file of your MTA to get more specific information.
> I hope this helps.
> - oliver
> Nachricht vom Montag 08 Oktober 2001 17:49:
> > Thanks for reading this. I've just installed Mailman 2.0.6 on Redhat
> > Linux 7.1, and need help.
> >
> > Messags I send to the "test" list are posted (I can see them in the
> > archives), but not mailed to the recipients. The smtp log in the
> > mailman/logs directory shows this error:
> >
> > Oct 08 13:43:23 2001 (891) All recipients refused: (110, 'Connection
> > timed out').
> >
> > I've tried the DELIVERY_MODULE = 'Sendmail' option, without success, and
> > changed the SMTPPORT = 25, both in mm_cfg.py, also without any change.
> >
> > All ideas welcome. Thanks in advance.
> >
> > Bill


Thanks for your note. The problem wasn't with the MTA (sendmail, btw), but
rather with the path between  Mailman and sendmail. I was confused by the fact
that the mail was getting INTO my list, but not out: since the wrapper is
called in either case, and the sendmail logs showed nothing, and I had tried
the command line call to sendmail (ahem), I didn't think it was a problem.

I finally realized that the IPTABLES ruleset didn't include an allowance for
port 25 on the loopback interface, and put in an ALLOW statement which has
cured the problem, at least with the DELIVERY_MODULE = 'SMTPDirect' option.

Now, just out of curiousity: can somebody tell me why it didn't work when I
had DELIVERY_MODULE = 'Sendmail' in my mm_cfg.py file? That's a "command line"
call to sendmail, isn't it?


Bill Horne

Bill Horne

More information about the Mailman-Users mailing list