[Mailman-Users] Majordomo vs. mailman wrapper program

Will Nordmeyer will at willspc.net
Wed Sep 5 22:17:01 CEST 2001

Got a new one...

I did the link as that doc mentioned.  (not sure why I missed that doc for the first several days of install attempt)...

Now, in 
/usr/adm/sm.bin, I have
lrwxrwxrwx   1 root     root           26 Sep  5 13:46 mm_wrapper -> /home/mailman/mail/wrapper
lrwxrwxrwx   1 root     root           17 Jul  5 20:42 procmail -> /usr/bin/procmail
lrwxrwxrwx   1 root     root           27 Jul  5 20:42 vacation.pl -> /usr/local/sbin/vacation.pl
lrwxrwxrwx   1 root     root           28 Sep  1 18:45 wrapper -> /usr/local/majordomo/wrapper                                            

My alias file has:
## mytest mailing list
## created: 05-Sep-2001 mailman
mytest:                  "|mm_wrapper post mytest"
mytest-admin:            "|mm_wrapper mailowner mytest"
mytest-request:          "|mm_wrapper mailcmd mytest"                          

Sep  5 15:43:01 raq sendmail[9019]: PAA09019: from=<NONE>, size=0, class=0, pri=0, nrcpts=0, proto=ESMTP, relay=localhost [] 

If I change the aliases to /home/mailman/mail/wrapper, I get...
Sep  5 16:06:12 raq sendmail[10027]: QAA10025: to="|/home/mailman/mail/wrapper mailowner mytest", delay=00:00:00, xdelay=00:00:00, mailer=prog, stat=Operating system error     

if I run the ./wrapper mailowner mytest from the console prompt, it seems to give me the first error again:
Sep  5 16:09:02 raq sendmail[10154]: QAA10154: from=<NONE>, size=0, class=0, pri=0, nrcpts=0, proto=ESMTP, relay=localhost []  

I really don't like how stupid I'm looking at this point...

I would GREATLY appreciate any advice, input, etc... (short of random confirmations that I'm stupid please. :-))


----- Original Message ----- 
  From: Josh Rabinowitz 
  To: Will Nordmeyer 
  Sent: Wednesday, September 05, 2001 1:38 PM
  Subject: Re: [Mailman-Users] Majordomo vs. mailman wrapper program

  Dear Will:

  I think this problem is explained in the file README.SENDMAIL
  in the mailman-2.0.6 distribution-- here is the relevant

    --- excerpt from README.SENDMAIL ---
    For example, if you've installed Mailman in the standard location, you
    can just execute these commands (you might have to do these as root):

       % cd /etc/smrsh
       % ln -s /home/mailman/mail/wrapper wrapper

      One complication: if you're running Majordomo and Mailman
    simultaneously (i.e. in the process of migrating from MD to MM :),
    then you might have a small problem because Majordomo also uses a
    program called `wrapper'.  In this case, Paul Tomblin suggests calling
    the Mailman symlink `mailman_wrapper', and changing the alias entries
    to call this instead of `wrapper'.  You might want to hack bin/newlist
    to output this instead.
    --- end excerpt ---

  It sounds like /usr/adm/sm.bin is your equivalent of /etc/smrsh, so 
  probably you can address it by setting up a dir with the appropriate 
  links - -write back if you want.


  >OK... here's the latest...
  >My RAQ3 came with majordomo installed... 
  >in the /usr/adm/sm.bin directory is a hardlink to the wrapper 
  >program within majordomo:
  >lrwxrwxrwx 1 root root  28 Sep  1 18:45 wrapper -> 
  >When I tried sending mail to willslist-admin, I get this error...
  >    ----- The following addresses had transient non-fatal errors -----
  >"|/home/mailman/mail/wrapper mailowner willslist"
  >     (expanded from: willslist-admin)
  >    ----- Transcript of session follows -----
  >wrapper: Trying to exec /usr/local/majordomo/mailowner failed: No 
  >such file or directory
  >     Did you define PERL correctly in the Makefile?
  >     HOME is HOME=/usr/local/majordomo,
  >     PATH is PATH=/bin:/usr/bin,
  >     SHELL is SHELL=/bin/sh,
  >     MAJORDOMO_CF is MAJORDOMO_CF=/usr/local/majordomo/majordomo.cf
  >451 "|/home/mailman/mail/wrapper mailowner willslist"... Operating 
  >system error
  >Warning: message still undelivered after 4 hours
  >Will keep trying until message is 5 days old                                  
  >How do I fix THIS headache?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.python.org/pipermail/mailman-users/attachments/20010905/47b59294/attachment.html 

More information about the Mailman-Users mailing list