[Mailman-Users] problems with cgi-gid and mail-gid

Shlomit Afgin vshlomit at wicc.weizmann.ac.il
Tue Apr 9 10:10:54 CEST 2002

We downloaded and compiled mailman-2.0.8 on solaris 2.7 .
The installation was done on mail server running solaris2.7.
We tried to configure our web server (also solaris 2.7) to get the gui
interface for mailman , using nfs mount disk from mail server onto web
We have the cgi-gid on our web server different from gid of the daemon
that runs mail on mail server.
So , we recompiled all the soft with

--with-cgi-gid=88891 and --with-mail-gid=88891.
Everything looked OK and we got giu interface of the first mailing list.

But when we try to post a message to the mailing lits we get the
following error:

.....The following address had permanent fatal errors ....
"|/export/mailman/mail/wrapper post wicclist

.....Transcript of session follows ...

Failure to exec script   WANTED gid 88891 GOT gid 1.(reconfigure to take
554 5.3.0 "|/export/mailman/mail/wrapper post wicclist
... unknown mailer error 2.

How can we compile mailman to use wrapper in both gid's.

Thank you

Please send answers to

camelia.botez at weizmann.ac.il

More information about the Mailman-Users mailing list