[Mailman-Users] Bug in Mailman version 2.0.3

Richard Barrett R.Barrett at ftel.co.uk
Wed Dec 4 17:25:05 CET 2002


You are going to get a better response if you quote exactly from the 
Mailman $prefix/logs/error logfile the information that was logged into it 
when the  problem occurred.

You should find that there is a Python traceback immediately prior to the 
line that reads "CORRUPT ARCHIVE FOR LIST <listname>". This may contain 
useful diagnostic information that will help people help you.

The problem is not necessarily with the list's .mbox file but more likely 
to be with the $prefix/archives/private/<listname>/pipermail.pck used to 
support the HTML archiving done by the builtin Pipermail archiver.

Repost with more information from the MM error log.

You could try rebuilding the problem list's HTML archives from its mbox 
archive using $prefix/bin/arch

This might reconstruct the HTML archive from the list's mbox but you should 
back up the list's archives before you try this.

Note that the mbox is used to create the HTML archive NOT the other way around!

At 15:39 04/12/2002, MITCHELL,STEPHANE (HP-France,ex2) wrote:
>Hello,
>
>I've upgraded Mailman 2.0.3 to 2.0.13... and it's always the same thing :o)
>Any idea someone, please ?
>
>S. MITCHELL
>
>-----Original Message-----
>From: Jeremy Portzer [mailto:jeremyp at pobox.com]
>Sent: Wednesday, November 06, 2002 7:27 PM
>To: MITCHELL,STEPHANE " "(HP-France,ex2)
>Subject: Re: [Mailman-Users] Bug in Mailman version 2.0.3
>
>
>Hello,
>
>Is there any reason you cannot upgrade to the latest version, 2.0.13?
>This might fix this particular problem.
>
>--Jeremy
>
>On Tue, 2002-11-05 at 10:25, MITCHELL,STEPHANE (HP-France,ex2) wrote:
> > Hello,
> >
> > I am novice with Mailman, but I have to admistrate it :o)
> >
> > I get this message when I try to open my Web interface for administration
>:
> >
> > Bug in Mailman version 2.0.3
> >
> > We're sorry, we hit a bug!
> >
> > Please inform the webmaster for this site of this problem. Printing of
> > traceback and other system information has been explicitly inhibited, but
> > the webmaster can find this
> > information in the Mailman error logs.
> >
> > In logs files, I found : ARCHIVES CORRUPT ... I have renamed my
><list>.mbox
> > to <list>.mbox.sav, created a new <list>.mbox
> > and run ./arch
> > I have always the save message...
> > I tried to find anything in the logs files, but I found nothing explicite
>!
> >
> > My OS is HP UX 10.20
> >
> > Thank's for any help !
> >
> > Stephane Mitchell
> >
> > PS. Sorry for my english, I'm French :o)
> >
> > ------------------------------------------------------
> > Mailman-Users mailing list
> > Mailman-Users at python.org
> > http://mail.python.org/mailman/listinfo/mailman-users
> > Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
> > Searchable Archives:
>http://www.mail-archive.com/mailman-users%40python.org/
> >
> > This message was sent to: jeremyp at pobox.com
> > Unsubscribe or change your options at
> > http://mail.python.org/mailman/options/mailman-users/jeremyp%40pobox.com
> >
>
>
>------------------------------------------------------
>Mailman-Users mailing list
>Mailman-Users at python.org
>http://mail.python.org/mailman/listinfo/mailman-users
>Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
>Searchable Archives: http://www.mail-archive.com/mailman-users%40python.org/
>
>This message was sent to: r.barrett at ftel.co.uk
>Unsubscribe or change your options at
>http://mail.python.org/mailman/options/mailman-users/r.barrett%40ftel.co.uk




More information about the Mailman-Users mailing list