FW: [Mailman-Users] can't resolve "smrsh: mailman not available for sendmail programs" issue

Keith Steward ksteward at keithsteward.com
Mon Dec 30 02:27:24 CET 2002


Yes, the /etc/smrsh/ directory contains a symbolic link to the mailman
wrapper:  ie.
  /etc/smrsh/mailman -> /usr/local/mailman/mail/mailman

I've also tried replacing the symbolic link with a copy of the compiled
mailman wrapper executable -- again, still get the same error.



Keith L. Steward, Ph.D.    work: 408-957-7777 x300   cell: 408-250-5213
Email: keith at BioinformaticsTech.com
Web: http://www.BioinformaticsTech.com
Pager: http://www.skytel.com/Paging/pageme.cgi?pin=8499479,1
          or call 1-888-849-9479
FAX:  408-226-3215 408-40 (call ahead for setup)

-----Original Message-----
From: Larry Rosenman [mailto:ler at lerctr.org] 
Sent: Sunday, December 29, 2002 2:08 PM
To: Keith Steward; mailman-users at python.org;
mailman-developers at python.org
Subject: Re: [Mailman-Users] can't resolve "smrsh: mailman not available
for sendmail programs" issue

Did you put links to the $MAILMANHOME/mail/mailman program in the CMDDIR
directory for your copy of SMRSH?


--On Sunday, December 29, 2002 13:31:35 -0800 Keith Steward 
<ksteward at keithsteward.com> wrote:

> Arghhhh!!!
> After several attempts to get Mailman installed (including stable 2.0
> final, and newest 2.1rc1), and hitting unresolvable "smrsh: mailman 
> not available for sendmail programs" issues (despite trying numerous 
> things), i'm just about ready to give up. I've been able to get 
> Mailman to send  email to a new subscriber asking for confirmation, 
> and the /var/log/maillog shows the response to the subscriber's 
> confirmation email, but ALWAYS reporting the damn smrsh
> problem:  -------- /var/log/maillog segment ------------
>  sendmail[30785]: gBTEUjD30785: from=<ksteward at keithsteward.com>, 
> size=2749, class=0, nrcpts=1, 
> jI3
> Ph8KAAAAQAAAAX+S3UuMa1xGjtQAFXc7j, proto=ESMTP, daemon=MTA,
> relay=steward-family.com []  smrsh: uid 8: attempt to
> use mailman request test1
>  sendmail[30786]: gBTEUjD30785: to="|/etc/smrsh/mailman request 
> test1", ctladdr=<test1-request at justice4injuredworkers.org> (8/0), 
> delay=00:00:00, xdelay=00:00:00, mailer=prog, pri=31743, dsn=5.0.0, 
> stat=Service unavailable  sendmail[30786]: gBTEUjD30785: gBTEUjD30786:

> DSN: Service unavailable  sendmail[30786]: gBTEUjD30786: 
> to=<ksteward at keithsteward.com>, delay=00:00:01, xdelay=00:00:01, 
> mailer=esmtp, pri=31843, relay=keithsteward.com. [], 
> dsn=2.0.0, stat=Sent (gBTERt820385 Message accepted for delivery)
>  ----------- end segment ---------------
> System information:
>  RedHat 7.2, Sendmail 8.11.6, Python-2.2.2
>  The /etc/aliases includes:
>  ## test1 mailing list
>  test1:              "|/etc/smrsh/mailman post test1"
>  test1-admin:        "|/etc/smrsh/mailman admin test1"
>  test1-bounces:      "|/etc/smrsh/mailman bounces test1"
>  test1-confirm:      "|/etc/smrsh/mailman confirm test1"
>  test1-join:         "|/etc/smrsh/mailman join test1"
>  test1-leave:        "|/etc/smrsh/mailman leave test1"
>  test1-owner:        "|/etc/smrsh/mailman owner test1"
>  test1-request:      "|/etc/smrsh/mailman request test1"
>  test1-subscribe:    "|/etc/smrsh/mailman subscribe test1"
>  test1-unsubscribe:  "|/etc/smrsh/mailman unsubscribe test1"  Sendmail
> can send and receive successfully from a regular (non-Mailman) account

> on the machine running Mailman.  newaliases was run after the above 
> aliases were added.  /etc/smrsh contains:
>   lrwxrwxrwx    1 root     root           31 Dec 29 05:38 mailman ->
> /usr/local/mailman/mail/mailman  The permissions on the
> /usr/local/mailman/mail/mailman wrapper are:   -rwxr-sr-x    1 mailman
> mailman     39593 Dec 29 05:16 mailman
> Things i've tried:
>   * ./configure --with-mail-gid=mail
>   * path to mailman wrapper in /etc/aliases as either
> '/usr/local/mailman/mail/mailman' or '/etc/smrsh/mailman'
>   * ln -s /etc/smrsh/mailman /usr/local/mailman/mail/mailman
>   * copying the compiled wrapper (/usr/local/mailman/mail/mailman)
> /etc/smrsh    * changing uid/gid of the wrapper to mailman, to mail
>   * by-passing sendmail as a test as in: echo "confirm" | 
> /etc/smrsh/mailman request test1, only to get mailman complaining
> the gid    * by-passing root/sendmail as in: sudo -u mail "test" |
> /etc/smrsh/mailman request mailman, only to still get a gid complaint.
> * restarting Sendmail daemon and Mailman's qrunner daemon after config

> changes. By the way, i've done extensive reading of:
>   * Mailman INSTALL
>   * Mailman README.LINUX
>   * Sendmails various READMES pertaining to SMRSH etc
>   * the mailman-developers list archives
> At this point, i'm out of ideas on what to try, except to abandon
> and switch to something like Majordomo, etc.   And frankly i think
> run out of time.  I've spent several evenings on this already.
> Getting any kind of mailing list up and running is more important than

> the bells and whistles that Mailman offers. thanks.
> -keith s.

Larry Rosenman                     http://www.lerctr.org/~ler
Phone: +1 972-414-9812                 E-Mail: ler at lerctr.org
US Mail: 1905 Steamboat Springs Drive, Garland, TX 75044-6749

More information about the Mailman-Users mailing list