[Mailman-Users] wrapper seems to not be sgid'ing..

Mark Ash mrash at drshouse.com
Tue Feb 12 19:54:07 CET 2002

Am trying to run mailman v2.0.8 with postfix on SuSE v7.2.  Am getting 
the error at the bottom of the page.  I've rebuilt, installed and 
configured  mailman.  I built it using the correct gid values for mail 
and cgi.
I ran the check_perms and when it's set to what it ideally wants, wrapper 
is mail.mail  and sgid.
Even if I chgrp postfix wrapper and leave it sgid, I get the same error.  
It's like the sgid is failing.
I can use some help... Everything associated with mailman seems to be 
ready, just can't mail to it.  All users that aren't mailing-list related 
can send and receive mail just fine.  This seems to be specific to 
wrapper not sgid'ing..

Gid	name		Comment
51	postfix	mail runs as this
65534	nogroup	web runs as this

Feb 12 11:21:34 thedr postfix/local[5508]: 254ED15E733: 
to=<testing at drshouse.com>, relay=local, delay=0, status=bounced (Command 
died with status 2: "/home/mailman/mail/wrapper post testing". Command 
output: Failure to exec script. WANTED gid 51, GOT gid 65534.  
(Reconfigure to take 65534?) )
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.python.org/pipermail/mailman-users/attachments/20020212/cadc943f/attachment.html 

More information about the Mailman-Users mailing list