[Mailman-Users] Web interface saves no settings or info!

Ted M Harapat ted-mailman at mob.net
Tue Feb 19 22:17:35 CET 2002

Actually, I am using IE 6.x for this. 

After reading this, I went ahead and tried this in Netscape 4.79 but the same 
thing happened.

I have only one more quirky thing with my setup, I should add. The hostname 
isn't really in DNS as I'm calling it. Because this is a brand new system thats 
about to take over an old non-Mailman list server, I simply set up my local 
hosts file to reflect the new IP so only I could access it. Oh, and this is also 
a virtual domain/website on the new linux system, which is why I had to do that 
host-file trick so the host-headers would make it come up. 

Could either of those two things matter? 



Quoting Jon Carnes <jonc at haht.com>:

> This is definitely a Frequently Asked Question...  Undoubtedly you are
> using
> Konqueror as your web browser.  Konqueror cannot handle the new cookie
> layout (in version 2.0.8).  Since it mis-reads the cookie, the
> authentication it sends when you Post is incorrect.  Thus none of your
> changes are accepted.
> Use Netscape and your problems will be gone.  Newer versions of IE have
> the
> same problem, but the work around for IE is to set the web site with
> your
> Mailman install to "Trusted".  I have no idea why that works... except
> maybe
> it reads in the cookie without filtering it for bad things.
> Jon Carnes
> ----- Original Message -----
> From: "Ted M Harapat" <ted-mailman at mob.net>
> To: <mailman-users at python.org>
> Sent: Tuesday, February 19, 2002 3:40 PM
> Subject: [Mailman-Users] Web interfase saves no settings or info!
> > Hi. I've setup mailman a couple other time in the past year and it
> worked
> near
> > flawlessly except for a few tiny things that were worked out. I've
> installed
> > 2.0.8 on a new (Mandrake Linux) system just yesterday.
> >
> > It all installed fine as always, and I made lists and sent some mails
> to
> them.
> > So it appeared to work. So I went to the web interface to start to
> configure
> > them and add the users to the lists. Here's where the problem started.
> I
> put in
> > all the info and hit "Submit Your Changes" and it went to that next
> page
> as
> > normal but none of my changes were accepted. So I tried non-useradd
> features and
> > the same thing happened... nothing was saving! I've checked
> permissions to
> make
> > sure the mailman group had access to all the files in his home
> directory.
> I even
> > decided to start from scratch and completely reinstall but that
> produced
> the
> > same results. I can't imagine that there is something so drastically
> different
> > from my old installs (of 2.0.6) compared to now that I can't figure
> it
> out. Can
> > anyone make any suggestions?
> >
> > I have gone through all of the web & mailman logs and they are
> reporting
> no
> > errors related to the mailman account or directories or permissions.
> It
> all
> > appears perfectly correct.
> >
> > Please advise.
> >
> >
> > -ted
> >
> > ------------------------------------------------------
> > Mailman-Users maillist  -  Mailman-Users at python.org
> > http://mail.python.org/mailman/listinfo/mailman-users

More information about the Mailman-Users mailing list