[Mailman-Users] Re: owner of config.db

Scott Spence scott at noggon.com
Thu Feb 21 13:11:00 CET 2002

Hi Gerald,

I wish I could say that is my solution - I am still having problems and am
sure it is to do with the httpd or python binary not running on a suid
partition - therefore I am going to ask for further info from the list and
if required make changes later (when I am closer to the machine)

I would appreicate knowing if your fstab options that are on the partition
of python or apache or mailman have the suid (or 'defaults') options



PS I include this into the mailing list for its information.

On Thu, 21 Feb 2002, Gerald Volp wrote:

> Scott,
> We solved the problem here.
> We looked over it again and changed one or two things. The main problem
> probably was, that I was root, when I ran "./make install". That caused the
> subdirectories of /home/mailman to be incorrect (SUID).
> I understand now: The change of config.db to wwwrun is not the problem,
> that's just the way it ist, but the cron scripts of mailman quickly get it
> back to mailman's ownership. And THIS did not work out and produced me lots
> of errors. mailman had no rights to get back the files into his own
> ownership. :-(
> We deleted the whole tree of /home/mailman and ran ./configure and ./make
> install again, beeing user mailman.
> Mit freundlichen Grüßen,
>   (best regards)
> Gerald Volp
> VISTEC Internet Service GmbH
> Tel.: +49-611-22038 Fax: -22701
> gav at vistec.de http://vistec.de

Scott Mobile: +34 65 337 8573
Fiona Mobile: +34 65 337 8574

More information about the Mailman-Users mailing list