FW: [Mailman-Users] qfiles building up + (111, 'Connection refused')

Simon, imagine media simon at imaginemedia.co.uk
Wed Jan 2 21:34:25 CET 2002

Morning David,

I have solved my problem! Just to recap for others I was having the
following problem:

Messages in qfiles are not being posted, and I had this error in logs/smtp:

"Dec 20 09:12:03 2001 (10830) All recipients refused: (111, 'Connection
Dec 20 09:12:03 2001 (10830) smtp for 1 recips, completed in 0.002 seconds"

After checking everything many times and rebuilding Mailman etc it turns out
that Sendmail was binding only to the loopback interface by default, so when
Mailman tried to send out on localhost:25 the connection was refused as
there was now smtp service bound to this port. Running 'netstat -a' or 'lsof
-i | grep sendmail' gave:

sendmail  24441 root    4u  IPv4 32620009       TCP
ns0.imagineinternet.co.uk:smtp (LISTEN)

But we should see:

sendmail  24441 root    4u  IPv4 32620009       TCP *:smtp (LISTEN)

if mailman is to work! Note last two fields showing
localhost.localdomain:smtp in first example (rather than *:smtp)!

To fix this you will need to tinker with
/usr/share/sendmail-cf/cf/redhat.mc and look for:

dnl This changes sendmail to only listen on the loopback device
dnl and not on any other network devices. Comment this out if you want
dnl to accept email over the network.
DAEMON_OPTIONS(`Port=smtp,Addr=, Name=MTA')

Do what it suggests and comment (dnl) out the 'DAEMON_OPTIONS' line and save
the file. Then 'make redhat.cf' and 'cp redhat.cf /etc/sendmail.cf'

Every thing should then work! Good luck and Happy New Year!

Simon Lorenz
Systems Modelling
Imagine Media Ltd
simon at imaginemedia.co.uk
Kennel House, Hammersley Lane,
Penn, Bucks, HP10 8HE, UK
t 01494 812890   
f 01494 813151
m 07977 149955

> From: David Krebsbach <davidk at expressdata.net>
> Date: Mon, 31 Dec 2001 11:32:30 -0500
> To: "'simon at imaginemedia.co.uk'" <simon at imaginemedia.co.uk>
> Subject: Mailman problem
> I am having the same problem with RH7.2 and Mailman 2.08. I can send and
> recieve email fine with sendmail when my MTA entry in the sendmail.cf file
> is my correct IP address, but I get connection refused when Mailman tries
> posting to the list. If I change my IP address to the local
> loopback( in my sendmail.cf file I can send email through Mailman
> but cannot send back to the list from the outside since my MTA in sendmail
> is set to the loopback instead of my correct mail DNS. Have you solved it
> yet??

More information about the Mailman-Users mailing list