[Mailman-Users] MM 2.0.10 -> 2.0.11 upgrade problem

David B. O'Donnell atropos at fates.org
Wed Jun 12 00:59:42 CEST 2002

Setup now:

Mailman 2.0.10
Python 2.1
Mac OS X Server 10.1.4 (Mac OS X release 10.1.5)

Mailman works fine except that I cannot edit any of the HTML pages--Mailman 
crashes when trying to do so.

I figured I'd upgrade to 2.0.11 before trying it again and filing a bug 
report, but when I attempt the make install step I get the following:

Compiling /Users/mailman/Mailman/versions.py ...
Traceback (most recent call last):
  File "bin/update", line 31, in ?
    from Mailman import Utils
  File "/Users/mailman/Mailman/Utils.py", line 33, in ?
    import cgi
SystemError: NULL result without error in call_object

I saw a post in May with a similar error trace, but suspect the individual 
was on a Linux machine due to the "python-devel" reference. I built the 
version of Python on my machine direct from source.

So... is the error I'm seeing above due to my version of Python? Should I 
upgrade it to 2.2.1 (from python.org)?

Has anyone else experienced the HTML editing problem, and if so is upgrading 
to 2.0.11 the route to get it fixed?

David B. O'Donnell - atropos at fates.org - www.fates.org
Help cats in need: http://www.fancycats.org/
"Thoughtful consumption is the enemy of marketing."
  -- Scott Hazen Mueller

More information about the Mailman-Users mailing list