[Mailman-Users] missing cgi-bin scripts after install

saul saul at twenteenthcentury.com
Sun Jun 23 23:33:20 CEST 2002


I've just been trying to install mailman on a redhat linux (2.4.19-pre7) 
virtual server.

Everything seems to go ok, but I get the following error on make install:


[mailman at twenteenth mailman]$ bin/check_perms 
Traceback (innermost last): 
File "bin/check_perms", line 281, in ? 
File "bin/check_perms", line 202, in checkmail 
mode = statmode(wrapper) 
File "bin/check_perms", line 74, in statmode 
return os.stat(path)[ST_MODE] 
OSError: [Errno 2] No such file or directory: '/home/mailman/mail/wrapper' 


I then make a directory at /home/mailman/mail/wrapper and chmod it as 
described in the install instructions . After doing this, running 
/bin/check_perms -f returns "no problems found".

Then, when I check my cgi-bin, it's empty, so of course, nothing works.

I've tried make clean / make install again using two different versions 
(2.0.11 and 2.0.8) and neither makes any difference, I get the same error on 
the first attempt, and still nothing in my cgi-bin.

I found a thread about this on this list archive

( http://mail.python.org/pipermail/mailman-users/1999-February/000411.html )

but the suggested solution is adding a line to mailman-2.0.8/src/common.h ... 
I checked common.h in version 2.0.11 and 2.0.8 and found the line already 
there.. so no joy there. 

Does anyone have any ideas?



More information about the Mailman-Users mailing list