[Mailman-Users] 2.1b4 installation problem

Gianluca Sforna giallu at chemiome.chm.unipg.it
Wed Oct 30 12:20:49 CET 2002

This seems to me a python-related problem, but since I never had a
mailing list software installed, I write to this list hoping someone
could help...

System info:

OS:      Trustix secure linux 1.5
MTA:     postfix-0.0.20010228.pl08
Pyhton   1.5.2

At first I tried mailman 2.0.13 and, while I was able to install it and
see the web interface, I realized that for a tighter integration with
postfix I could install 2.1b.

So I downloaded 2.1b4 (I tried even the CVS version) but, since pyhton 2
is not shipped with my server distribution, I had to download it and
recompile from the sources.

Everything seems fine with python since I can succesfully configure;
make ; make install the mailman package but, when looking at the
mailman/admin (or any other web page) I got this error:

Bug in Mailman version 2.1b4+

We're sorry, we hit a bug!

If you would like to help us identify the problem, please email a copy
of this page to the webmaster for this site with a description of what
happened. Thanks!

Traceback (most recent call last):
  File "/home/mailman//scripts/driver", line 61, in run_main
    import paths
  File "/home/mailman//scripts/paths.py", line 60, in ?
    import korean.aliases
ImportError: No module named aliases

Python information:

Variable Value
sys.version 2.2.2 (#2, Oct 29 2002, 20:16:46) [GCC 2.95.3 20010315
sys.executable /usr/bin/python2.2
sys.prefix /usr
sys.exec_prefix /usr
sys.path /usr
sys.platform linux2

now I tought: I don't care korean language so maybe I can remove that
line... actally that error is gone but now I have again a "bug":

Traceback (most recent call last):
  File "/home/mailman//scripts/driver", line 63, in run_main
    from Mailman.Logging.StampedLogger import StampedLogger
  File "/home/mailman/Mailman/Logging/StampedLogger.py", line 18, in ?
    import time
ImportError: No module named time

>From this I understand my python build is somewhat broken (i.e. it
cannot find modules), but I really do not understand how to fix it.

I do know this is not a bug, but a serious UBD :) so please help me if
you can.


More information about the Mailman-Users mailing list