[Mailman-Users] Problem Upgrading to 2.1b3

Mike Kercher mike at CamaroSS.net
Sun Sep 8 04:55:12 CEST 2002

This is the configure I ran:

./configure --prefix=/home/mailman --with-mail-gid=41 --with-cgi-id=48

No problems there, then I run make install and get the following:

Compiling /home/mailman/Mailman/htmlformat.py ...
Compiling /home/mailman/Mailman/i18n.py ...
Listing /home/mailman/Mailman/pythonlib ...
Compiling /home/mailman/Mailman/versions.py ...
Traceback (most recent call last):
  File "bin/update", line 47, in ?
    from Mailman import MailList
  File "/home/mailman/Mailman/MailList.py", line 40, in ?
    from email.Utils import getaddresses, formataddr, parseaddr
ImportError: cannot import name formataddr
make: *** [update] Error 1

gcc is 2.96
python is 2.2.1
RH 7.2

Anyone have any idea?  This was an attempt to upgrade from 2.0.13 non-rpm install.


More information about the Mailman-Users mailing list