[Mailman-Users] MM & Mac OS X ?

Brent Rossow brossow at mac.com
Mon Sep 30 02:23:59 CEST 2002

I searched the archives for the past several months and found very little
mention of anyone running Mailman on Mac OS X.  Back in January, when I was
setting up a new mail server for our agency, I went with Mac OS X 10.1 for
the plain old SMTP/POP needs, but I also needed a listserv package.  At the
time, I tried unsuccessfully to get Mailman set up but had no luck in the
timeframe I was allotted.  Instead, I've been running Majordomo pretty
successfully since then, using Webmin for my various list administrators to
do their thing.

I'm now in a position to re-evaluate our listserv options as I'm planning to
step up to Mac OS X Server 10.2 (Jaguar) in the next month or two (probably
implementing over the Thanksgiving break.)  I like the features it includes
and it integrates perfectly with our all-Mac network.  I'd like to take
another look at Mailman, but this time I'm not too proud to ask for help.

Long story short, I'm running Mac OSXS 10.2 on a development machine.  I
spent the better part of this afternoon trying to get it configured.  I've
got the developer tools installed, of course, and followed the MM directions
to the absolute letter.  I've created the mailman user and group as
directed.  I created the mailman directory with proper permissions.
Everything looked good when I did config and 'make install' but when I use
the check_perms script (after creating a test list) I get the following:

directory permissions must be at least 02775:
directory permissions must be at least 02775:
directory permissions must be at least 02775: /usr/local/mailman/lists/test
Traceback (most recent call last):
  File "bin/check_perms", line 281, in ?
  File "bin/check_perms", line 202, in checkmail
    mode = statmode(wrapper)
  File "bin/check_perms", line 74, in statmode
    return os.stat(path)[ST_MODE]
OSError: [Errno 2] No such file or directory:

The first three lines I understand the problem, although I don't know why MM
didn't set the permissions properly when I created the list.  I have no idea
what the rest is saying.  I know the last line is looking for the file in
question, which apparently wasn't created during the install process.  The
'wrapper' file is simply missing -- why, I have no idea.  I should note here
that aside from the first three lines, I got exactly the same error
immediately after running the make and before any lists were created.  I
reinstalled MM from scratch twice with identical results.  Using the -f flag
didn't fix anything, nor did running the entire install and post-test
process as root (and I know that's discouraged; I was trying everything I
could think of to get it to work.)

If anyone has successfully installed MM on Mac OS X, I'd love to get some
pointers.  Majordomo is working adequately, but I'd like my listserv package
to be more than just "adequate."  Any help is greatly appreciated!


More information about the Mailman-Users mailing list