[Mailman-Users] MM & Mac OS X ?

Peter Tattersall ptatters at zerobyzero.ca
Mon Sep 30 06:35:06 CEST 2002

How helpful this is remains to be seen, but I have been running mailman 
with qmail under OS X for a couple of months now. I installed under 
10.1 first, using fink to install python, and installing qmail 
essentially from scratch. After I installed qmail I did a fair amount 
of testing to ensure that qmail was accepting and delivering mail 
properly. This is running on my home system, but my daughters' systems 
are networked via a router, and the whole network is accessing the net 
through an ADSL connection with static IP and my own domain name. I 
didn't install mailman until I had mail working properly for everyone 
and was sure that there were no open relays.

I installed 2.0.12 first, then upgraded almost immediately to 2.0.13. I 
had a couple of problems with permissions, so I reconfigured with 
various options set. All of this was still under 10.1. After the 
upgrade to 10.2 I had no obvious problems - everything worked - but 
when I checked the system log I found I was getting a lot of complaints 
about pre-binding on python. I haven't worked out what's going on 
there. It's not that the message doesn't make sense, but that it is 
intermittent. If I reboot, sometimes the pre-binding message goes away. 
I haven't spent much time on it, and won't as long as the system 
operates properly. Eventually fink will catch up with 10.2 or I'll 
rebuild with the system's version of python - but not today.

My needs are light. On a busy day I might get ten incoming messages and 
direct them to a couple of hundred address. I've had one glitch so far, 
but it was a qmail freeze which resulted from the trigger file being 
left in an odd state after I killed the system one night while playing 
with some early software. I should know better than to run version 0.01 
of anything....  I reset the perms on the trigger and rebooted, and 
eventually qmail came out of its trance. Mailman itslef has been solid. 
I was running LetterRip under OS 9, and my users really appreciate the 
web interface and archiving which mailman provides.

Bottom line is, mailman can run under 10.2 but since I haven't tried to 
install directly I doubt I can help with your problem, though I'm 
willing to try. I just hope this is encouraging enough that you 

What are you using for mail service?

On Sunday, September 29, 2002, at 08:23  PM, Brent Rossow wrote:

> I searched the archives for the past several months and found very 
> little
> mention of anyone running Mailman on Mac OS X.  Back in January, when 
> I was
> setting up a new mail server for our agency, I went with Mac OS X 10.1 
> for
> the plain old SMTP/POP needs, but I also needed a listserv package.  
> At the
> time, I tried unsuccessfully to get Mailman set up but had no luck in 
> the
> timeframe I was allotted.  Instead, I've been running Majordomo pretty
> successfully since then, using Webmin for my various list 
> administrators to
> do their thing.
> I'm now in a position to re-evaluate our listserv options as I'm 
> planning to
> step up to Mac OS X Server 10.2 (Jaguar) in the next month or two 
> (probably
> implementing over the Thanksgiving break.)  I like the features it 
> includes
> and it integrates perfectly with our all-Mac network.  I'd like to take
> another look at Mailman, but this time I'm not too proud to ask for 
> help.
> Long story short, I'm running Mac OSXS 10.2 on a development machine.  
> I
> spent the better part of this afternoon trying to get it configured.  
> I've
> got the developer tools installed, of course, and followed the MM 
> directions
> to the absolute letter.  I've created the mailman user and group as
> directed.  I created the mailman directory with proper permissions.
> Everything looked good when I did config and 'make install' but when I 
> use
> the check_perms script (after creating a test list) I get the 
> following:
> directory permissions must be at least 02775:
> /usr/local/mailman/archives/private/test.mbox
> directory permissions must be at least 02775:
> /usr/local/mailman/archives/public/test.mbox
> directory permissions must be at least 02775: 
> /usr/local/mailman/lists/test
> Traceback (most recent call last):
>   File "bin/check_perms", line 281, in ?
>     checkmail()
>   File "bin/check_perms", line 202, in checkmail
>     mode = statmode(wrapper)
>   File "bin/check_perms", line 74, in statmode
>     return os.stat(path)[ST_MODE]
> OSError: [Errno 2] No such file or directory:
> '/usr/local/mailman/mail/wrapper'
> The first three lines I understand the problem, although I don't know 
> why MM
> didn't set the permissions properly when I created the list.  I have 
> no idea
> what the rest is saying.  I know the last line is looking for the file 
> in
> question, which apparently wasn't created during the install process.  
> The
> 'wrapper' file is simply missing -- why, I have no idea.  I should 
> note here
> that aside from the first three lines, I got exactly the same error
> immediately after running the make and before any lists were created.  
> I
> reinstalled MM from scratch twice with identical results.  Using the 
> -f flag
> didn't fix anything, nor did running the entire install and post-test
> process as root (and I know that's discouraged; I was trying 
> everything I
> could think of to get it to work.)
> If anyone has successfully installed MM on Mac OS X, I'd love to get 
> some
> pointers.  Majordomo is working adequately, but I'd like my listserv 
> package
> to be more than just "adequate."  Any help is greatly appreciated!
> Thanks,
> Brent
> ------------------------------------------------------
> Mailman-Users mailing list
> Mailman-Users at python.org
> http://mail.python.org/mailman/listinfo/mailman-users
> Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
> Searchable Archives: 
> http://www.mail-archive.com/mailman-users%40python.org/

More information about the Mailman-Users mailing list