[Mailman-Users] database error message when upgraded to 2.1.2

NOW Website Coordinator webperson at now.org
Wed Apr 30 00:08:08 CEST 2003

At 05:32 PM 04/29/2003 -0400, Jon Carnes wrote:

>On Tue, 2003-04-29 at 13:29, NOW Website Coordinator wrote:
> > I didn't get any error messages upgrading from 2.1.1 until I ran
> > mailmanctl.  Then I got:
> > Starting Mailman's master qrunner.
> > [mailman at www2 mailman-2.1.2]$ Warning: Database (2.5.12) != program 
> (2.6.2)
> > version.
> >
> > This is on Linux Red Hat (recent conversion from Solaris).  Python 2.2.
> >
> > What needs to be done?  What does it mean?  Thanks.
> >
>Did you copy all the files over from Solaris onto Red Hat Linux... Or
>install the same version of Mailman on Red Hat Linux and then copy over
>the ~mailman/lists/.. and ~mailman/archives/.. ?

I installed/compiled Python and Mailman (at the time 2.1.1) on the RH Linux 
and everything worked fine (although it's not in production yet).  I copied 
the lists and archives over.

Then on Sunday I upgraded from 2.1.1 to 2.1.2 and got the error message 
above.  I didn't get any error messages previously, although it hadn't been 
rigorously tested.

check_db [list] does not report anything.

>Was Mailman running previously on this box and you just upgraded it?

No, it wasn't.

>What version did you upgrade it from? Did you clear out all the queues
>before installing the upgrade?

There weren't any queues, because so far this isn't a live server.

Thanks for your help.

>Just to be on the safe side, I would look in the following directories
>and backup & delete any older files:

>Could you describe more precisely how you did the "conversion".
>Also, what happens when you run a check_db on the existing lists?
>Jon Carnes

More information about the Mailman-Users mailing list