[Mailman-Users] Upgrade install - "Could not import paths!"

Richard Barrett r.barrett at openinfo.co.uk
Mon Aug 4 15:37:04 CEST 2003

On Monday, August 4, 2003, at 12:08  pm, david.gordon wrote:

> Richard Barrett wrote on Sun 3 Aug 2003 at 16:14 +0100
>> You should have two files in you Mailman runtime installation:
>> $prefix/pythonlib/korean
>> $prefix/pythonlib/korean.pth
> Apologies, I don't do this often enough to know what I (er, or you) am 
> on
> about.

$prefix means the path of the directory in which you installed Mailman 
into, default /usr/local/mailman, unless you changed it by adding the 
--prefix= option when you ran .configure. That is why the documentation 
files such as Mailman's INSTALL also use this way of referring to the 
site specific installation directory

Similarly, by $build I mean the path of the directory in which you ran 
./configure and make install to install Mailman.

I am suggesting you check for the presence of certain files related to 
the problem you report in the Mailman build and installation directory.

> Where exactly these files are eludes me. I'm willing to admit my
> ignorance if people here are willing to help me learn! ;-)
>> and I would also expect the following files in your Mailman build
>> directory after having run ./configure and make install:
> The "build directory" being...
> Anyway, no matter. I've reinstalled and somehow solved the problem. I
> think I used --with-mail-gid=admin & --with-cgi-gid=admin (plus --
> prefix=/home/mailman)
> However.... I now have an "Internal Server Error" when trying to get to
> the admin pages via the web. I remember reading about this when I first
> installed Mailman. I know its a cgi permissions problem but I cant
> remember how to fix it. I've read the docs. I've tried reinstalling 
> using
> --with-cgi-gid=web as that's what my httpd.conf says. Didn't work 
> though.
> My httpd error_log says
>> [Mon Aug  4 11:52:01 2003] [error] [client x.x.x.x] Premature end of
>> script headers: /home/mailman/cgi-bin/private

I think that every (although I am open to correction) Mailman script 
that is run will execute and 'import paths' statement which in turn 
will execute an 'import korean'. The problem with these import 
statemeets is what you reported in your original post and which I was 
trying to help you diagnose.

Unless you previously reported problem has been fully corrected then 
this may be the latest manifestation of a failing import statement.

Dose anything show in the Mailman's error log $prefix/logs/error?

> My VirtualHost for this domain is set up and was working with Mailman 
> 2.0.x.

Yes but you have now upgraded you installation to MM 2.1.2 and it 
appears that something went wrong when you originally dir so; which is 
why you were getting these. Once these new problems are corrected then 
you virtual hosts should probably work OK.

I refer you back to the exercise, from my previous response, in running 
Python from the command line and typing in some statement to see if 
they work as a way of trying to confirm/diagnose the precise nature of 
your installation's problem.

> Thanks again.
> -- 
> david.gordon

More information about the Mailman-Users mailing list