[Mailman-Users]HandlerAPE error: WAS :Listserv wide announcements?

Bruce Mitzit bruce at uchicago.edu
Tue Aug 12 23:35:53 CEST 2003


You're right, thanks. I have a number of files from the old install:

	 Apr 16  2002 /usr/local/mailman/Mailman/Handlers/HandlerAPI.py
	 Dec 20  2002 /usr/local/mailman/ bin/digest_arch
	Dec 20  2002 /usr/local/mailman/ bin/move_list
a bunch of cgi's,
	Apr 16 2002  ../cron/qrunner

I removed HandlerAPI.py, renamed cron/qrunnerBU (with current date) 
to qrunner. Gave it 755 perms.

This has not seemed to have calmed things down.

If I wanted to do a clean install --start from scratch-- what 
directories in /usr/local/mailman/ should I keep?

Thanks a lot for your help.


>On Tuesday, August 12, 2003, at 07:23  pm, Bruce Mitzit wrote:
>>At 3:33 PM +0100 8/12/03, Richard Barrett wrote:
>>>On Tuesday, August 12, 2003, at 03:10  pm, Bruce Mitzit wrote:
>>>>Hello, MM users---
>>>>After upgrading from mailman 2.0.9 to mailman-2.1.2, and tweaking 
>>>>all the things I could find to tweak, I still get this error 
>>>>emailed to me at the rate of about three a minute:
>>>>Your "cron" job on urserver.uchicago.edu
>>>>/usr/local/bin/python -S /usr/local/mailman/cron/qrunner
>>>>produced the following output:
>>>>Traceback (most recent call last):
>>>>   File "/usr/local/mailman/cron/qrunner", line 89, in ?
>>>>     from Mailman.Handlers import HandlerAPI
>>>>   File "/usr/local/mailman/Mailman/Handlers/HandlerAPI.py", line 26, in ?
>>>>     from Mailman.pythonlib.StringIO import StringIO
>>>>ImportError: No module named pythonlib.StringIO
>Well some of your old MM installation is executing to generate these 
>warnings. The traceback is from MM 2.0.x code as the 
>Mailman/Handlers/HandlerAPI.py file is not in the MM 2.1.2 
>distribution; well its in MM 2.0.13 but not in MM 2.1.2 on my test 
>>>With Mailman 2.1.2 the qrunner is no longer run as a cron job.
>>>The 2.1.2 qrunners are run as daemons started by the 
>>>$prefix/bin/mailmanctl script.
>>>Looks like, maybe, you did not remove the mailman user's crontab 
>>>before doing the update and the old 2.0.9 crontab is still trying 
>>>to do stuff.
>>>Did you take a look at the section 'UPGRADING FROM 2.0.x to 2.1' 
>>>in the UPGRADING file in your MM 2.1.2 build director as part of 
>>>your tweakingy?
>>Richard et. al.--
>>Well, yeah, I did read that thing. I did not remove (in Solaris 7) 
>>/var/spool/cron/cronjobs/mailman prior to the install.
>>So, I've rm'd that cronjob. We'd been running that cron from root 
>>anyway, so I commented all out from there as well.  I did a 
>>configure, make install all over again. I still am getting the same 
>>error message by email. Any suggestions? The original install of MM 
>>made me feel pretty smart. This one makes me feel dumb.
>If messages reporting the same error are still turning up then 
>either the mail system has a backlog it is drip feeding you or there 
>is still another crontab which executes the old MM qrunner script in 
>place and enough old MM code extant to generate the error.
>Richard Barrett                               http://www.openinfo.co.uk


More information about the Mailman-Users mailing list