[Mailman-Users] How are the URLs in the webinterface built?

Richard Barrett R.Barrett at ftel.co.uk
Tue Feb 25 14:59:30 CET 2003

At 11:49 25/02/2003, Goeran Zaengerlein wrote:
>Hello everyone,
>I installed Mailman 2.1.1 on my Suse 8.1 Linux box (together with Apache
>and Postfix).
>The installation went smooth, except that the webinterface does not work
>as expected: when I go to the administration of a list (in my case:
>lists.mydomain.info/admin.cgi/listname) the URLs on the page are contain
>the hostname of my linuxbox instead of the the domainname I put in the
>respective variables in mm_cfg.py. Here is an excerpt from mz mm_cfg.py:
>--- snip ---
>DEFAULT_EMAIL_HOST = 'mydomain.info'
>DEFAULT_URL_HOST = 'lists.mydomain.info'
>DEFAULT_URL_PATTERN = 'http://%s/'
># For backwards compatibility.  Note: DEFAULT_URL_PATTERN must end in a
>--- snap ---
>lists.mydomain.info is an Apache virtual host and points to
>Here the excerpt from my httpd.conf:
>--- snip ---
>ServerName lists.mydomain.info
>DocumentRoot /usr/local/mailman/cgi-bin
>Options ExecCGI FollowSymLinks
>Alias /icons/ /usr/local/mailman/icons/
>Alias /pipermail/ /usr/local/mailman/archives/public/
>--- snap ---
>The hostname of my system is "1234567890.pureserver.info".

Tying running $prefix/bin/fix_url.py - the instructions on how to use it 
are near the top of the file fix_url.py .

Why the problem? Did you create the lists before making the changes to 
mm_cfg.py? That often causes the problem.

>Can anyone tell me why the URLs in the administration pages use that
>hostname instead of the DEFAULT_URL_HOST i specified? The problem is,
>like this the webinterface does not work for me.
>Thanks a lot for your help,

More information about the Mailman-Users mailing list