[Mailman-Users] Another upgrade problem (2.0.13 -> 2.1); pending admin request page hosed

Ed Osinski osinski at cs.nyu.edu
Tue Jan 14 20:45:33 CET 2003


I upgraded from 2.0.13 to 2.1, and I run into a problem when trying to
access the "Tend to pending moderator requests" page of a pre-existing
list.  I get:

Bug in Mailman version 2.1

We're sorry, we hit a bug!

If you would like to help us identify the problem, please email a copy
of this page to the webmaster for this site with a description of what
happened. Thanks!


Traceback (most recent call last):
  File "/usr/mailman/scripts/driver", line 87, in run_main
  File "/usr/mailman/Mailman/Cgi/admindb.py", line 226, in main
    num = show_pending_subs(mlist, form)
  File "/usr/mailman/Mailman/Cgi/admindb.py", line 264, in show_pending_subs
    pendingsubs = mlist.GetSubscriptionIds()
  File "/usr/mailman/Mailman/ListAdmin.py", line 161, in GetSubscriptionIds
    return self.__getmsgids(SUBSCRIPTION)
  File "/usr/mailman/Mailman/ListAdmin.py", line 150, in __getmsgids
    for k, (type, data) in self.__db.items():
ValueError: unpack tuple of wrong size

Any idea what I can do to get rid of this?

- Ed

More information about the Mailman-Users mailing list