[Mailman-Users] 2.1 and Sendmail moderation issues

Warren Woodward scratch at xmission.com
Mon Jan 20 13:00:59 CET 2003

Warning:  newbie admin question incoming.

I am running Mailman 2.1 and Sendmail with RedHat 8.0.  I have my sendmail 
simply configured to refuse relay for anything but local host deliveries.  
i.e., people logged into Squirrel Mail can send, but I have no SMTP auth 
or SMTP after POP set or anything like that.  

So, it seems that Mailman will reject any post to any list to the
moderator for approval, even with all the proper moderation tags set.  
I'm assuming this is a problem with my MTA, and admittedly I'm a bit
unclear as to what else I need to do (though I plead ignorance, and I'm
sure it's something simple).  I have the aliases properly built (I think)
and I have run 'newaliases" after the fact.  Everything seems fine in that
arena, so seeing as I can post to the lists from a local account, even as
an accepted non-member, I assume I have some unforgiving setting in my
sendmail config that I cannot find that is bypassing the list filters and
requiring moderator approval for every post, including that of the list
administrator, which is an account offsite of the host machine.
So, the questions are, 1) is there something simple I need to change in my 
sendmail.cf?  and 2) would it be better to move to exim or postfix (no 
sendmail love would be lost, I just wanted to learn it).  I scoured the 
list archives and didn't come across this particular question.  If someone 
can link me to something that sends me on my way, I'll be much obliged,  
and if there is a more verbose explanation that would be appropriate to 
share on this list, even more so.  

Thanks in advance.

warren woodward
XMission DSL
warrenw at xmission.com
(801) 303-0819

"The United States, as the world knows, will never start a war."
			-JFK, American University, June 10, 1963

More information about the Mailman-Users mailing list