[Mailman-Users] Archives page not found (Noob.Q)

Keith Mastin kmastin at beechtree.ca
Tue Jan 28 07:49:31 CET 2003

Hi Matthew,

>> >>     Alias /pipermail/ "/web/mlib/data/mailman/archives/public/"
>> >> 
>> >>     <Directory "/web/mlib/data/mailman/archives/public">
>> >>         Options FollowSymLinks
>> >>         AllowOverride None
>> >>         Order allow,deny
>> >>         Allow from all
>> >>     </Directory>
>> >> 
>> >
>> >Alias /pipermail/ /var/mailman/archives/public/
>> ><Directory /var/mailman/archives>
>> >        Options +FollowSymlinks
>> ></Directory>
>> Yeah, that didn't work. I'm leaning more toward it being a permissions 
>> problem. Here's a line from error_log:
>> [Mon Jan 27 18:57:32 2003] [error] [client] Directory index 
>> forbidden by rule: /web/mlib/data/mailman/archives/public/members/
>Make sure bin/check_perms doesn't give any problems (just to rule that out).

That came up clean almost from the start... just a couple snafus the first 
time and clean after. Now, however...

[root at mail mailman]# /usr/local/mailman/bin/check_perms -f
bash: /usr/local/mailman/bin/check_perms: @PYTHON@: bad interpreter: No 
such file or directory

>But this is an apache config problem.  I'd go thru the apache .conf file and
>take out thoes <Directory> options (to make sure they're not causing the
>problem) or # them out.  Make sure you restart apache to have the new
>settings take effect.  Then try with just the 2 lines
>Alias /pipermail/ /home/mailman2/archives/public/
>ScriptAlias /mailman/ "/home/mailman2/cgi-bin/"
>Thats all I have in my httpd.conf in refrence to mailman.

Tried that too... still no joy. What should the perm on the archives tree 
be? Thanks again.

More information about the Mailman-Users mailing list