[Mailman-Users] Errors with Mailman 2.1 final

Simon White simon at mtds.com
Wed Jan 29 12:58:15 CET 2003


I was running Mailman 2.1b6, I just upgraded because I was having some
problems. I always get the latest before coming to a list (I'm new here,
just point me to some FAQ or other).

First of all the UPGRADING file doesn't cover from 2.1bN to 2.1final,
but that's minor. I fly by the seat of my pants and go "make update" and
it seemed to work OK and everything is sorta running.

However, python is a resource hog so everything is slow. Anyone with
tips? I have python2.2.2 rolled by yours truly from tar.gz

This bugs me though, I get it at startup:

Traceback (most recent call last):
  File "/home/mailman/bin/qrunner", line 270, in ?
  File "/home/mailman/bin/qrunner", line 230, in main
  File "/home/mailman/Mailman/Queue/Runner.py", line 59, in run
    filecnt = self._oneloop()
  File "/home/mailman/Mailman/Queue/Runner.py", line 88, in _oneloop
    msg, msgdata = self._switchboard.dequeue(filebase)
  File "/home/mailman/Mailman/Queue/Switchboard.py", line 158, in
    msg = cPickle.load(msgfp)
TypeError: __import__() argument 1 must be string without null bytes,
not str

Things seem to work, but I don't like that :(

I saw an error on the HTTPS site too, a Traceback with different params,
but I can't reproduce it so I won't bother y'all with it now


|-Simon White, Internet Services Manager, Certified Check Point CCSA.
|-MTDS  Internet, Security, Anti-Virus, Linux and Hosting Solutions.
|-MTDS  14, rue du 16 novembre, Agdal, Rabat, Morocco.
|-MTDS  tel +212.3.767.4861 - fax +212.3.767.4863

More information about the Mailman-Users mailing list