[Mailman-Users] upgrade from 2.1beta3 to 2.1 final

G. Armour Van Horn vanhorn at whidbey.com
Sun Jun 1 20:30:57 CEST 2003

Well, that was reassuring, so I ran "ps aux | grep mail" to dig out the syntax
for mailmanctl, and stopped it with

/usr/bin/python2 /home/mailman/bin/mailmanctl -s -q stop

I went to /usr/scr/mailman.2.1.2 and ran the exact same commands I used last
October to install 2.1b3. (Yes, I keep these things around, I hate haveing to
figure them out every few months.)

./configure --with-mail-gid=99 --with-cgi-gid=99 --prefix=/home/mailman
 make install

When I restarted mailmanctl I get

[mailman at virtuoso templates]$ /usr/bin/python2 /home/mailman/bin/mailmanctl -s
-q start
Site list is missing: mailman

The web interface appears to be running fine, but ps reports no mailman
processes, and messages are not being processed.

I realized that I was running as root when I did the install, so I did "chown -R
mailman:mailman *" from /home/mailman, and got the same result. I then
reconfigured and reinstalled. I had a couple of permission problems in foreign
language template directories, didn't see any other errors, but I still come up
with the same error on startup.

Mailman is totally down, so if anybody has a hint I'm standing by!


"Barry A. Warsaw" wrote:

> >>>>> "MS" == Marius Scurtescu <mariuss at lightspeed.ca> writes:
>     MS> I am running Maiman 2.1 beta 3 and I would like to
>     MS> upgrade to the final release.
> That's an easy upgrade.  Just stop mailmanctl, then configure and make
> install right over 2.1b3.  Then start mailmanctl again and you should
> be good to go.
> -Barry

Sign up now for Quotes of the Day, a handful of quotations
on a theme delivered every morning.
Enlightenment! Daily, for free!
mailto:twisted at whidbey.com?subject=Subscribe_QOTD

For web hosting and maintenance,
visit Van's home page: http://www.domainvanhorn.com/van/

More information about the Mailman-Users mailing list