[Mailman-Users] Update: Help with mailpasswds error in CRON job

Tomas (NW7US) nw7us at hfradio.org
Wed Jun 4 14:01:51 CEST 2003


Jim Tittsler provided some help with a bit of code that allowed me to produce 
the following:

> Running hostname.hostname()...
> Loading list rlogbeta (unlocked)
> hfradio.org
> Loading list pdadev (unlocked)
> seasystems.accessnow.com
> Loading list jcarc_oh (unlocked)
> hfradio.org
> Loading list jcarc_repeater (unlocked)
> hfradio.org
> Loading list jcarc_fieldday (unlocked)
> hfradio.org
> Loading list jcarc_chat (unlocked)
> hfradio.org
> Loading list aaa0wa-list (unlocked)
> wa.mars.hfradio.org
> Finalizing

So, it seems that the script in ~/mailman/bin can see the host_name - but, when 
I am in ~/mailman/cron, the mailpasswd script cannot.  When I run mailpasswd 
with just one list:

> mailpasswds -l rlogbeta

I get:

Traceback (most recent call last):
  File "./mailpasswds", line 218, in ?
    main()
  File "./mailpasswds", line 210, in main
    msg.send(sitelist, **{'errorsto': sitebounce,
  File "/home/mailman/Mailman/Message.py", line 221, in send
    self['Message-ID'] = Utils.unique_message_id(mlist)
  File "/home/mailman/Mailman/Utils.py", line 634, in unique_message_id
    msgid = '<mailman.%d.%d.%d.%s@%s>' % (
  File "/home/mailman/Mailman/MailList.py", line 130, in __getattr__
    raise AttributeError, name
AttributeError: host_name

which is the same error the CRON gets.

I don't see any problem - all lists have a valid host name.

So, what could be causing this?  Any ideas?

73 de Tomas, NW7US (AAR0JA/AAM0EWA)
--
: Propagation Editor, CQ/PopComm Magazines : http://hfradio.org/ :
: Brinnon, Washington 122.93W 47.67N : CW SSB DIGITAL DX-Hunting :
: A creator of solutions -- http://accessnow.com/ -- Perl Rules! :
: Washington State MARS Emergency Operations Officer - (AAM0EWA) :
: WA State Army MARS Webmaster  for  http://wa.mars.hfradio.org/ :
: 10x56526, FISTS 7055, FISTS NW 57, A.R. Lighthouse Society 144 :







More information about the Mailman-Users mailing list