[Mailman-Users] Sendmail 8.12.8 and Mailman

Kevin Carlson khcarlso at bellsouth.net
Wed Mar 5 04:12:48 CET 2003


Thanks very much for the help.  I created the default directory you 
described below, recreated the symlink to wrapper, and everything works 


Ashley M. Kirchner wrote:

> Kevin Carlson wrote:
>> Today I upgraded to sendmail 8.12.8 and afterward smrsh seemed to 
>> stop working.  Prior to the upgrade everything worked fine.
>> I still have smrsh installed, it is still enabled in the sendmail.cf 
>> file and there is still a symbolic link in /etc/smrsh called 
>> 'wrapper' that points to /home/mailman/mail/wrapper.
>> The error I am receiving is:
>> smrsh: "wrapper" not available for sendmail programs (stat failed)
>> 554 5.0.0 Service unavailable
>> I am at a loss for this since the files are all still in place.  Does 
>> anyone have any ideas?
>    How did you upgrade?  /etc/smrsh isn't the default from 
> sendmail.org's source, which leads me to think you had a vendor 
> supplied binary installation.  If that's the case, then you should use 
> the vendor's update to upgrade sendmail.  However, since you seem to 
> already have installed 8.12.8, (and I'm assuming you grabbed the 
> source from sendmail.org), the default smrsh path is /usr/adm/sm.bin - 
> which isn't created for you.

More information about the Mailman-Users mailing list