[Mailman-Users] 14 hours and still not there

Jon Carnes jonc at nc.rr.com
Wed Mar 12 17:14:29 CET 2003

----- Original Message -----
From: "Paul H Byerly" <paul at thcwd.com>
> Thee:
> >I don't think this is exactly true.  Your chroot environment has a
> >limited amount of UserID's and GroupID's that are available to be used
> >inside (and really outside as well) the Chroot.
>       I've seen this mentioned on a number of Ensim lists, it just won't
> work with anything over 755.  When I get far enough it matters, I'll dig
> into it more.

Interesting, because I remember using UID and GID's that were in the 1000+
range for the chroot (but that was six months ago so I could just be

>       As for lack of web pages, I assume that is because the cgi programs
> don't run?  Are the web pages real or created on the fly?  And if real,
> where are they supposed to reside?  I tried manually creating pages and
> could not get to them, apparently a redirect was sending me else where.  I
> have not dissected it yet, but any hints would be appreciated.
The web-pages are generated via the GGI's, but you can check them out
 - Chroot yourself
 - su as the local chrooted user that runs the webserver (generally the
admin of the chroot)
 - run the admin cgi from the command line:  ~mailman/cgi-gin/admin

This should dump out the source of a web-page to the command line (like when
you look at a web-page and click on "View Source".  It's a simple check.  If
that works then your Mailman install is working fine and the problems must
be in the Chroot web-server setup.

Good Luck - Jon Carnes

More information about the Mailman-Users mailing list