[Mailman-Users] Problem solved: it was the MTA

Elena Fraboschi elena at inca.math.indiana.edu
Wed Mar 12 19:45:35 CET 2003

ugh, you must be a developer... :-)  (just in case, here comes
another one ;-))

My problem was that mailman received all fine, queued all fine,
and never delivered a thing.  Obviously my sendmail was running.
When I changed DELIVERY_MODULE from SMTPDirect to Sendmail,
it worked just fine.

Now, I do not understand this:

First you wrote:

That's a pretty strong warning against using this in production.

And then you wrote:

"There is nothing wrong with using sendmail as your MTA with mailman.  Lots
of people do this (despite sendmail's horrid .cf file, IMO ;)."

So, my problem (one of my many problems :-)) is that, I suppose, I
do not know what the hell is SMTPDirect, except that it is not something
standard in Solaris 8, because I have the full distribution.

Now, might mailman work if I just put SMTP instead of SMTPDirect?
Any comments?

As for all the warnings you cited, right, I read them.  I read them
*after* I discovered what the problem was, which took me 24 hours...
My only point is that I would not see anything wrong if the README
file, the one we read when we install the thing, had said:

"By the way, take a look at Defaults.py.  It may well be that your
sistem does not use SMTPDirect bla bla bla."

Best, elena

More information about the Mailman-Users mailing list