[Mailman-Users] Mailman won't work - can you help?

John Barrus john at johnbarrus.com
Sun Nov 2 04:19:52 CET 2003

I just installed Mandrake 9.1 and also installed Mailman 2.1.3 and Apache
2. I'm trying to get mailman to work, but having no success.


When I go to http://www.llef.org/mailman/admin/, I get:

Internal Server Error

The server encountered an internal error or misconfiguration and was
unable to complete your request.
Apache-AdvancedExtranetServer/2.0.47 (Mandrake Linux/1.4.91mdk)
mod_perl/1.99_08 Perl/v5.8.0 mod_ssl/2.0.47 OpenSSL/0.9.7a PHP/4.3.1
Server at www.llef.org Port 80

The error in the error_log file is:

[Sat Nov 01 19:00:52 2003] [error] [client] Premature end of
script headers: admin

So, I try to run the admin script in /usr/local/mailman/cgi-bin/admin and
I get:
[root at www cgi-bin]# ./admin
Content-type: text/html

<title>Mailman CGI error!!!</title>
<h1>Mailman CGI error!!!</h1>
The Mailman CGI wrapper encountered a fatal error. This entry is being
stored in your syslog:
Group mismatch error.  Mailman expected the CGI
wrapper script to be executed as group "apache", but
the system's web server executed the CGI script as
group "root".  Try tweaking the web server to run the
script as group "apache", or re-run configure,
providing the command line option `--with-cgi-gid=root'.</pre>
(Not surprising)

I su to user "apache" and try it again

[root at www cgi-bin]# su apache
[apache at www cgi-bin]$ ./admin
sh: ./admin: Permission denied

Well, why won't it run? I check the permissions...

[apache at www cgi-bin]$ ls -l | grep admin
-rwxr-sr-x    1 root     mail        36849 Nov  1 18:50 admin*
-rwxr-sr-x    1 root     mail        36857 Nov  1 18:50 admindb*
[apache at www cgi-bin]$ ls -l .. | grep cgi
drwxrwsr-x    2 root     mail         4096 Nov  1 18:50 cgi-bin/
[apache at www cgi-bin]$ ls -l ../.. | grep mailman
drwxrwsr-x   13 root     root         4096 Nov  1 18:50 mailman/

Seems like everything is setgid as it should be. I also chown'ed and
chgrp'd the files to the apache owner and group, but of course I had the
same result. bin/check_perms -f made all the files owned by "mail" again.

Just for fun, check the version I'm running...

[root at www mailman]# bin/version
Using Mailman version: 2.1.3

Here is my mailman.conf file that is "Included" in my httpd2.conf file. I
verified that it was included by putting a deliberate error in the file
and watching httpd not be able to start. Fixed the error and httpd started
up just fine.

# Configure Mailman's CGI scripts
ScriptAlias /mailman/ /usr/local/mailman/cgi-bin/
<Directory /usr/local/mailman/cgi-bin>
  Options -Indexes -FollowSymLinks -Includes ExecCgi
  AllowOverride None
  order allow,deny
  allow from all

# Configure the public archives
Alias /pipermail/ /usr/local/mailman/archives/public/
<Directory /usr/local/mailman/archives/public>
  Options -Indexes FollowSymlinks -Includes
  AllowOverride None
  order allow,deny
  allow from all

Any suggestions? I've reinstalled mailman several times, tried various
apache settings, and still no luck. I'm pulling my hair out over this -
any help would be greatly appreciated.


John Barrus

More information about the Mailman-Users mailing list