[Mailman-Users] The Mailman CGI wrapper encountered a fatal error

patkins patkins at killinglyschools.org
Tue Nov 4 15:19:14 CET 2003


Thanks for the help! I changed all the files in the cgi-bin to both root and mailman just to see if I could execute the files properly and neither worked. I compiled three different times using various flags to set guid, user, group etc. Nothing I do seems to fix this problem. Keep in mind the lists work perfectly! I just can't use the web admins.


On 03/Nov/2003 22:04:08, Jim Cole  wrote:
> On Monday, November 3, 2003, at 12:03 PM, patkins wrote:
> > The user and group exist:
> >
> > group > mailman:x:506:
> > passwd > mailman:x:506:506::/usr/local/mailman:/dev/null
> ....
> > Mailman CGI error!!!
> > The Mailman CGI wrapper encountered a fatal error. This entry is being 
> > stored in your syslog:
> > Failure to find group name mailman.  Try adding this group
> > to your system, or re-run configure, providing an
> > existing group name with the command line option --with-cgi-gid.
> Have you tried verifying the group outside of Mailman? For example have 
> you tried executing chgrp on some file using the mailman group? If that 
> works as expected, double check the group associated with the CGI 
> wrappers in Mailman's cgi-bin directory. A quick look at the code seems 
> to imply that either your group file is somehow broken or the group 
> settings are incorrect for one or more of your wrapper files.
> Jim

More information about the Mailman-Users mailing list