[Mailman-Users] List Not Found after upgrade to newest version

Richard Barrett r.barrett at ftel.co.uk
Wed Nov 5 09:46:00 CET 2003


On Tuesday, November 4, 2003, at 10:08  pm, Scott Berkman wrote:

> Thank you for the help.  I look through it, and found it obviously is 
> erring
> out on Utils.list_exists(listname), but I have no idea how to test that
> method and see why it is failing.  I looked back and checked the path 
> and
> list variables and all that, and it seems fine.  All the permissions 
> are
> fine, and no errors are written to the log.  Any ideas?
> 	-Scott

I just referred back to your original post.

The alias definition has the listname as 'Test' rather 'test'.

I am fairly sure this is the problem. The listnames in the alias 
definitions should always be case folded to lower case.

How did you come by the revised aliases during the upgrade?


> -----Original Message-----
> From: Richard Barrett [mailto:r.barrett at ftel.co.uk]
> Sent: Tuesday, November 04, 2003 2:43 PM
> To: Scott Berkman
> Cc: mailman-users at python.org
> Subject: Re: [Mailman-Users] List Not Found after upgrade to newest 
> version
> On Tuesday, November 4, 2003, at 01:25  am, Scott Berkman wrote:
>> Hello,
>> 	I run mailman on a Redhat machine, installed by up2date.  Everything
>> seems to work fine, including web interfaces, and listing the lists.
>> When a
>> message is sent to a list, an error mail is bounced back saying:
>>   ----- The following addresses had permanent fatal errors -----
>> "|/usr/local/mailman/mail/mailman post Test"
>>     (reason: 1)
>>     (expanded from: <test@[address]>)
> MM's $prefix/scripts/post delivery script is terminating abnormally 
> with an
> exit code of 1. This may or may not be due to the script not being 
> able to
> correctly identify the list termination of the post. Take a look at the
> script, it is only a few lines of simple Python code with comments 
> which say
> what it is doing.
> Are there any entries in Mailman's errorlog file ($prefix/logs/error)
> prefixed with the string post to indicate the nature of the problem?
>>    ----- Transcript of session follows ----- post script, list not
>> found:
>> test
>> 554 5.3.0 unknown mailer error 1
>> I run sendmail as my MTA, and everything works fine with that.
>> Here is a sample entry in my aliases file:
>> test:              "|/usr/local/mailman/mail/mailman post test"
>> test-admin:        "|/usr/local/mailman/mail/mailman admin test"
>> test-bounces:      "|/usr/local/mailman/mail/mailman bounces test"
>> test-confirm:      "|/usr/local/mailman/mail/mailman confirm test"
>> test-join:         "|/usr/local/mailman/mail/mailman join test"
>> test-leave:        "|/usr/local/mailman/mail/mailman leave test"
>> test-owner:        "|/usr/local/mailman/mail/mailman owner test"
>> test-request:      "|/usr/local/mailman/mail/mailman request test"
>> test-subscribe:    "|/usr/local/mailman/mail/mailman subscribe test"
>> test-unsubscribe:  "|/usr/local/mailman/mail/mailman unsubscribe test"
>> The list is officially named "Test" as listed by bin/list_lists, but I
>> tried
>> both test and Test in the aliases file, with no change.  I am of 
>> course
>> running newaliases whenever changing the aliases file.
>> 	Thank you for any help and ideas, also, please respond to me
>> directly.
>> 	-Scott
>> -----------------------------------------------------
>> Scott Berkman gte999p  berkman at aepizeta.org AIM-SB523
>> (404)873-4708         http://www.aepizeta.org/~codine
>> ------------------------------------------------------
>> Mailman-Users mailing list
>> Mailman-Users at python.org
>> http://mail.python.org/mailman/listinfo/mailman-users
>> Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py
>> Searchable Archives:
>> http://www.mail-archive.com/mailman-users%40python.org/
>> This message was sent to: r.barrett at openinfo.co.uk
>> Unsubscribe or change your options at
>> http://mail.python.org/mailman/options/mailman-users/
>> r.barrett%40openinfo.co.uk

More information about the Mailman-Users mailing list