[Mailman-Users] List Not Found after upgrade to newest version

Richard Barrett r.barrett at openinfo.co.uk
Wed Nov 5 10:27:35 CET 2003


Attached some input from Jon Carnes, who has a habit of being right.

Might be worth checking the value of the MM config variable 
LIST_DATA_DIR which should be defined in $prefix/Mailman/Defaults.py 
and may possibly be redefined in $prefix/Mailman/mm_cfg.py

The default is LIST_DATA_DIR = os.path.join(VAR_PREFIX, 'lists') in 
which case chase back to the definition of VAR_PREFIX.

You need to verify that VAR_PREFIX value + "/lists/" + <listname> 
contains files called config.pck, config.pck.last, config.db or 
config.db.last. Existence of one of these is what the check for list 
existence is looking at.

If that is not correct, you may need to redefine some MM config 
variables. If one is wrong then so might be others.

Take a look at the config value and let me know the results.


Begin forwarded message:

> From: Jon Carnes <jonc at nc.rr.com>
> Date: Tue Nov 4, 2003  8:13:58  pm Europe/London
> To: Richard Barrett <R.Barrett at ftel.co.uk>
> Subject: Re: [Mailman-Users] List Not Found after upgrade to newest 
> version
> Reply-To: jonc at nc.rr.com
> Richard, Looks like he's running RH9 which has a some-what munged 
> config
> file (it doesn't even point to the Mailman group name properly!).  I
> believe he needs to setup the proper entries in mm_cfg.py and then
> create the "mailman" site list.
> Good Luck in helping him out!
> Jon Carnes
> On Tue, 2003-11-04 at 14:43, Richard Barrett wrote:
>> On Tuesday, November 4, 2003, at 01:25  am, Scott Berkman wrote:
>>> Hello,
>>> 	I run mailman on a Redhat machine, installed by up2date.  Everything
>>> seems to work fine, including web interfaces, and listing the lists.
>>> When a
>>> message is sent to a list, an error mail is bounced back saying:
>>>   ----- The following addresses had permanent fatal errors -----
>>> "|/usr/local/mailman/mail/mailman post Test"
>>>     (reason: 1)
>>>     (expanded from: <test@[address]>)
>> MM's $prefix/scripts/post delivery script is terminating abnormally
>> with an exit code of 1. This may or may not be due to the script not
>> being able to correctly identify the list termination of the post. 
>> Take
>> a look at the script, it is only a few lines of simple Python code 
>> with
>> comments which say what it is doing.
>> Are there any entries in Mailman's errorlog file ($prefix/logs/error)
>> prefixed with the string post to indicate the nature of the problem?
>>>    ----- Transcript of session follows ----- post script, list not
>>> found:
>>> test
>>> 554 5.3.0 unknown mailer error 1
>>> I run sendmail as my MTA, and everything works fine with that.
>>> Here is a sample entry in my aliases file:
>>> test:              "|/usr/local/mailman/mail/mailman post test"
>>> test-admin:        "|/usr/local/mailman/mail/mailman admin test"
>>> test-bounces:      "|/usr/local/mailman/mail/mailman bounces test"
>>> test-confirm:      "|/usr/local/mailman/mail/mailman confirm test"
>>> test-join:         "|/usr/local/mailman/mail/mailman join test"
>>> test-leave:        "|/usr/local/mailman/mail/mailman leave test"
>>> test-owner:        "|/usr/local/mailman/mail/mailman owner test"
>>> test-request:      "|/usr/local/mailman/mail/mailman request test"
>>> test-subscribe:    "|/usr/local/mailman/mail/mailman subscribe test"
>>> test-unsubscribe:  "|/usr/local/mailman/mail/mailman unsubscribe 
>>> test"
>>> The list is officially named "Test" as listed by bin/list_lists, but 
>>> I
>>> tried
>>> both test and Test in the aliases file, with no change.  I am of 
>>> course
>>> running newaliases whenever changing the aliases file.
>>> 	Thank you for any help and ideas, also, please respond to me
>>> directly.
>>> 	-Scott
>>> -----------------------------------------------------
>>> Scott Berkman gte999p  berkman at aepizeta.org AIM-SB523
>>> (404)873-4708         http://www.aepizeta.org/~codine

More information about the Mailman-Users mailing list