[Mailman-Users] Messages not being relayed

Tom Esker tjesker at yahoo.com
Wed Nov 12 04:59:37 CET 2003


I set up mailman and it worked great for a couple of months but I just realized
that it stopped relaying messages a couple of weeks ago.  Here is what I've
done so far:

1. Made sure the cron daemon is running:
interdyne: {189} % ps -aux |grep cron |grep -v grep
interdyn 72690  0.0  0.1  1152  632  p2  T     8:46PM   0:00.01 man cron

2. Tried to start the mailmanctl daemon as apparently it is not running:
interdyne: {214} % ./mailmanctl start
Traceback (most recent call last):
  File "./mailmanctl", line 105, in ?
    from Mailman import mm_cfg
ImportError: No module named Mailman

(I found line 105 - but what does this error mean and what should I do about
it?)

3. Checked the aliases file - looks OK. Also reset the aliases hash table:
interdyne: {221} % vnewaliases
/etc/aliases: 122 aliases, longest 56 bytes, 4119 bytes total

4. Looked at the messages log file - is this OK?
<XX>Nov 11 21:40:01 sendmail[80431]: hAC2e1HP080431:
from=<tjesker at interdyne.com>, size=1132, class=0, nrcpts=1,
msgid=<005501c3a8c6$76ea1870$9002a8c0 at kitchen>, proto=SMTP,
relay=gso56-152-124.triad.rr.com [66.56.152.124]
<XX>Nov 11 21:40:01 sendmail[80439]: hAC2e1HP080431:
to="|/usr/local/mailman/mail/mailman post committee",
ctladdr=<committee at pack940.org> (126/0), delay=00:00:00, xdelay=00:00:00,
mailer=prog, pri=31357, dsn=2.0.0, stat=Sent

5. Made sure sendmail will relay 127.0.0.1:
interdyne: {243} % grep "Port" ./sendmail.cf
O DaemonPortOptions=Name=MTA
O DaemonPortOptions=Port=587, Name=MSA, M=E
#O ClientPortOptions=Address=0.0.0.0

6. Tried to run qrunner manually & got same error as above - but I don't know
what to do about it?
interdyne: {250} % python -S ./qrunner
Traceback (most recent call last):
  File "./qrunner", line 76, in ?
    from Mailman import mm_cfg
ImportError: No module named Mailman

7. Deleted all messages in the qfiles directory and below and tried sending a
test message - still nothing.

I'm running Mailman version 2.12 on FreeBSD 4.4-RELEASE #11 with sendmail.

Can anyone suggest what I might need to do to get Mailman working again?

Thanks

Tom Esker

__________________________________
Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard
http://antispam.yahoo.com/whatsnewfree




More information about the Mailman-Users mailing list