[Mailman-Users] Problem after upgrade: wrong group?

Jordan Hayes jmhayes at speakeasy.net
Sat Sep 13 19:22:20 CEST 2003

I'm upgrading from 2.0.13 to 2.1.2 and I followed all the directions and
when I sent my first message, I got this:

>    ----- Transcript of session follows -----
> Group mismatch error.  Mailman expected the mail
> wrapper script to be executed as group "mailman", but
> the system's mail server executed the mail script as
> group "other".  Try tweaking the mail server to run the
> script as group "mailman", or re-run configure,
> providing the command line option `--with-mail-gid=other'.
> 554 5.3.0 unknown mailer error 2

I ran configure the same way as before, and I put the new "mailman"
program in my sm.bin ...

% ls -l mailman wrapper
   2 lrwxrwxrwx   mailman -> /new/mailman/mail/mailman*
   2 lrwxrwxrwx   wrapper -> /old/mailman/mail/wrapper*
% ls -lL mailman wrapper
  74 -rwxr-sr-x   1 root     mailman    37732 Sep 13 10:19 mailman*
  72 -rwxr-sr-x   1 root     mailman    36096 Aug 31  2002 wrapper*

This has been working fine.  Any ideas?



More information about the Mailman-Users mailing list