[Mailman-Users] japanese_codecs problem

Dan Phillips dhphllps at memphis.edu
Sat Dec 4 06:35:38 CET 2004

On Dec 3, 2004, at 8:11 PM, Tokio Kikuchi wrote:
> Speedy Gonzalis wrote:
>> Using Mailman v 2.1.4 I keep getting the following error.
>> Nov 30 19:19:07 2004 admin(29952): 
>> /var/mailman/pythonlib/japanese/c/euc_jp.py:3: RuntimeWarning: Python 
>> C API version mismatch for module _japanese_codecs: This Python has 
>> API version 1011, module _japanese_codecs has version 1012.
>> I've searched the archives but didn't find anything.  Can someone 
>> help?
> We (Japanese) had a same problem report on our mailing list. It looked 
> like the package was made in a incompatible environment (by Fedora 
> Core). Maybe you can fix it by upgrading your python to 2.3, or 
> install mailman from source.

I get a very similar message each month when password reminders go out 
ever since I upgraded python to 2.3 for compatibility with Mailman 
2.1.5 (this is on OS X Server 10.2.8). Mailman was installed from 
source. The reminders seem to go out to my Japanese subscribers OK, and 
all the web pages work in Japanese; should I worry about it?


Dan Phillips
Associate Professor of Horn, University of Memphis
administrator: music.memphis.edu

More information about the Mailman-Users mailing list