[Mailman-Users] strange SMTP error when using Courier with Mailman

Mark Sapiro msapiro at value.net
Sun Dec 19 18:15:47 CET 2004

Igor Gueths wrote:
> Hello all. I am attempting to use Mailman-2.1.5 with Courier-0.46 and I 
> haven't had much luck as of yet in terms of getting it going. Right now 
> I have the mailman (site list), and a list called Igors_list which I am 
> currently working with. The aliases I currently have defined are as 
> follows: igors_list:             |/usr/local/mailman/mail/mailman post 
> igors_list
> igors_list-admin:       |/usr/local/mailman/mail/mailman admin 
> igors_list
> igors_list-bounces:     |/usr/local/mailman/mail/mailman bounces 
> igors_list
> igors_list-confirm:     |/usr/local/mailman/mail/mailman confirm 
> igors_list
> igors_list-join:        |/usr/local/mailman/mail/mailman join igors_list
> igors_list-leave:       |/usr/local/mailman/mail/mailman leave 
> igors_list
> igors_list-owner:       |/usr/local/mailman/mail/mailman owner 
> igors_list
> igors_list-request:     |/usr/local/mailman/mail/mailman request 
> igors_list
> igors_list-subscribe:    |/usr/local/mailman/mail/mailman subscribe 
> igors_list
> igors_list-unsubscribe: |/usr/local/mailman/mail/mailman unsubscribe 
> igors_list
> Note that in the aliases file everyone is on its individual line,, it 
> just got wrapped because of the text editor I'm using for this message. 

Your aliases look OK. Do you also have a set for the "mailman" list? You 
need those too.

> I tried sending a test message to igors_list at lava-net.com (after 
> subscribing myself through the admin interface). In my maillog file, I 
> got the following: Dec 19 10:42:09 shadwiga courierd: 
> newmsg,id=001A8123.41C5A151.000072AE: dns; localhost (localhost 
> [])
> Dec 19 10:42:09 shadwiga courierd: 
> started,id=001A8123.41C5A151.000072AE,from=<igueths at lava-net.com>,module=local,host=alias!.xalias/igors_list at lava+2dnet+2ecom!1018!102!/usr/lib/courier/etc/aliasdir!!,addr=<alias>
> Dec 19 10:42:09 shadwiga courierd: Waiting.  shutdown time=none, wakeup 
> time=none, queuedelivering=2, inprogress=2
> Dec 19 10:42:09 shadwiga courierlocal: 
> id=001A8123.41C5A151.000072AE,from=<igueths at lava-net.com>,addr=<".xalias/igors_list at lava+2dnet+2ecom"@lava-net.com>,size=561,success: 
> Message delivered.
> Dec 19 10:42:09 shadwiga courierd: 
> completed,id=001A8123.41C5A151.000072AE

I don't know Courier, but this seems to say the incoming message was 
delivered to Mailman and I think it was.

> However, in /usr/local/mailman/logs/smtp-failure I get this: Dec 19 
> 10:42:11 2004 (29012) Low level smtp error: (-2, 'Name or service not 
> known'), msgid: <mailman.7.1103470930.29014.igors_list at lava-net.com>
> Dec 19 10:42:11 2004 (29012) delivery to igueths at lava-net.com failed 
> with code -1: (-2, 'Name or service not known')
> Dec 19 10:42:11 2004 (29012) Low level smtp error: (-2, 'Name or service 
> not known'), msgid: <mailman.8.1103470930.29014.igors_list at lava-net.com>
> Dec 19 10:42:11 2004 (29012) delivery to igors_list-owner at lava-net.com 
> failed with code -1: (-2, 'Name or service not known')

It looks here as though Mailman has received your post and is now trying 
to deliver a "moderation required" or some such message to 
igueths at lava-net.com and then another message to 
igors_list-owner at lava-net.com (note the msgids are different and both 
are mailman generated messages, not your post). These attempted 
deliveries fail. This seems to be a Courier issue of some kind not 
directly involving aliases.

> I've been googling variants of this error message. One sollution I found 
> was to make sure there was an entry for localhost in /etc/hosts, and I 
> already have that. Another one was to set 
> SMTP_MAX_SESSIONS_PER_CONNECTION to a value greater than 0. I tried that 
> and I still got the same message in the smtp-failure log. Should I 
> perhaps try setting MTA to something like Sendmail, since Courier is 
> able to somewhat emulate it? Currently I have it set to Manual. I also 
> have DELIVERY_MODULE set to SMTPDirect. Is there any way I can turn up 
> Mailman's logging so that I might be able to figure out what it doesn't 
> like? Thanks!

MTA = 'Manual' is what you want. This only has to do with how aliases 
are communicated to the MTA during list creation/deletion. SMTPDirect is 
also the delivery you want.

I don't think this is a Mailman problem. I think it is a Mailman/Courier 
integration problem and Mailman is already reporting all it can.

I think Mailman is receiving mail from Courier, but is unable to send. 
the code '-1' and message (-2, 'Name or service not known') come from 
the outgoing MTA

You might try finding a Courier specific list or other Courier specific 
resources to get more information.

Mark Sapiro <msapiro at value.net>       The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the Mailman-Users mailing list